locked
Sharepoint 2010 - List in a webpart - checkboxes RRS feed

  • Question

  • We have a simple list and using it in a webpart.  How do we remove the checkbox next to the list item in that webpart?


    Sanjeev

    Monday, May 14, 2012 7:07 PM

Answers

  • Hi Sanjeev,

    In the view of the list - modify the "Tabular View" settings to unselect the option ‘Allow individual item checkboxes‘ - check this blog post for details.

    http://www.glynblogs.com/2011/02/removing-the-checkbox-on-list-items-in-sp2010.html

    Hope this helps!


    BlueSky2010
    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    • Proposed as answer by Paul Turner _ Monday, May 14, 2012 8:33 PM
    • Marked as answer by GuYuming Wednesday, May 16, 2012 8:16 AM
    Monday, May 14, 2012 8:32 PM
  • Hi Sanjeev,

    You can do this by editing the web part and then editing the current view.  Under the Tabular View section, uncheck the "Allow individual item check boxes" option.

    Edit: Whoops, I got beat to the punch.  I guess that's what I get for getting distracted and coming back to the tab!
    • Edited by Bob Guidinger Monday, May 14, 2012 8:43 PM
    • Marked as answer by GuYuming Wednesday, May 16, 2012 8:16 AM
    Monday, May 14, 2012 8:42 PM

All replies

  • Hi Sanjeev,

    In the view of the list - modify the "Tabular View" settings to unselect the option ‘Allow individual item checkboxes‘ - check this blog post for details.

    http://www.glynblogs.com/2011/02/removing-the-checkbox-on-list-items-in-sp2010.html

    Hope this helps!


    BlueSky2010
    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    • Proposed as answer by Paul Turner _ Monday, May 14, 2012 8:33 PM
    • Marked as answer by GuYuming Wednesday, May 16, 2012 8:16 AM
    Monday, May 14, 2012 8:32 PM
  • Hi Sanjeev,

    You can do this by editing the web part and then editing the current view.  Under the Tabular View section, uncheck the "Allow individual item check boxes" option.

    Edit: Whoops, I got beat to the punch.  I guess that's what I get for getting distracted and coming back to the tab!
    • Edited by Bob Guidinger Monday, May 14, 2012 8:43 PM
    • Marked as answer by GuYuming Wednesday, May 16, 2012 8:16 AM
    Monday, May 14, 2012 8:42 PM
  • Dear Sanjeev,

    To remove the checkboxes, you can follow the steps given by BlueSky2010 & Bob.

    Also, you can add a DataView WebPart and get the data from that specific list/Lib.. It will fetch the data as a read only too.

    Its additional benefits is, you can also avoid the Context menu around each item.

    Another option is, edit the XSLT List View Webpart and remove the check box field using SharePoint Designer.

    Hope, this will help you.


    Sandeep Parandekar MCTS
    http://www.parandekar.blogspot.com
    Please mark the post that answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.

    Tuesday, May 15, 2012 6:04 AM