locked
The service is unavailable RRS feed

  • Question

  • Hey everyone,

    visiting my application URL http://npruehs.azurewebsites.net/ yields "The service is unavailable."

    The service seems to be running, and no changes were made to the Docker container of the application. Restarting the service doesn't resolve the issue.

    Looking at the Logs in the Container Settings page yields "Error in retrieving logs."

    Is there any way of accessing any logs for further diagnostics I'm not aware of?

    Best regards,

    Nick


    Co-Founder of slash games. Trading card game geek. Microsoft MVP. Thoughts are my own.


    • Edited by npruehsMVP Wednesday, May 6, 2020 2:50 PM
    Wednesday, May 6, 2020 8:35 AM

Answers

  • I just changed the App Service Plan from F1 pricing tier to B1 - and back.

    Now, the application is running perfectly, I can see the whole Docker log as expected "Container Settings" page, access Kudu, and the "Log Stream" in the monitoring section.

    This is really weird, as I tried accessing the application multiple days in a row, double-checked the quotas, but found no indication why the application should't be working.


    Co-Founder of slash games. Trading card game geek. Microsoft MVP. Thoughts are my own.

    • Marked as answer by npruehsMVP Friday, May 8, 2020 3:49 PM
    Friday, May 8, 2020 3:49 PM

All replies

  • Hi Nick,

    Have you tried retrieving the logs from SCM...https://<yourappname>.scm.azurewebsites.net/api/logs/docker? 


    Thanks in advance, Ryan

    Thursday, May 7, 2020 4:15 PM
  • Hey Ryan,

    thanks for your answer! Your URL yields the same simple response:

    "The service is unavailable."

    Any other ideas?

    Best regards,

    Nick



    Co-Founder of slash games. Trading card game geek. Microsoft MVP. Thoughts are my own.

    Thursday, May 7, 2020 10:34 PM
  • Try going through the portal. Click on 'Advance Tools' to open Kudu.

    Once there, you can click on the Docker Logs link.


    Thanks in advance, Ryan

    Thursday, May 7, 2020 11:10 PM
  • That's the same link - with the same results:


    Co-Founder of slash games. Trading card game geek. Microsoft MVP. Thoughts are my own.

    Friday, May 8, 2020 9:28 AM
  • I just changed the App Service Plan from F1 pricing tier to B1 - and back.

    Now, the application is running perfectly, I can see the whole Docker log as expected "Container Settings" page, access Kudu, and the "Log Stream" in the monitoring section.

    This is really weird, as I tried accessing the application multiple days in a row, double-checked the quotas, but found no indication why the application should't be working.


    Co-Founder of slash games. Trading card game geek. Microsoft MVP. Thoughts are my own.

    • Marked as answer by npruehsMVP Friday, May 8, 2020 3:49 PM
    Friday, May 8, 2020 3:49 PM