locked
Refreshing while a playing a streaming video causes "multiple streaming" RRS feed

  • General discussion

  • Didn't know how to aptly describe my problem :p

     So basically i have a media server setup with a couple of videos published. I followed the quickstart guide on how to create a basic video player and set my source to mms://server/source and everything works fine. However, while my video is playing, and the user "accidentally" hits the refresh button, it seems like another stream comes down resulting in mainly the audio doubling up. Tongue Tied How do i prevent this from happening?

    Wednesday, July 18, 2007 12:07 PM

All replies

  • Could not reproduce this issue. I hit refresh multiple times and I can hear only a single track of sound. The application i tried is a media player created by a Microsoft Expression Encoder template.

    Wednesday, July 18, 2007 3:17 PM
  • Try to use Microsoft Expression Media Encoder. i find it very useful in creating a startup template for a media player application

    http://www.microsoft.com/expression/products/download.aspx?key=encoder 

    Wednesday, July 18, 2007 3:18 PM
  • I ran into similiar issue, I was using Blend 2 May download, debugging a my Silverlight Javascript application project with a live streaming video, even after I closed the browser and relaunched to test again, it would continue playing my previous live stream along with starting my new live stream, I should say, at least the audio was still playing. So I had numerous audio portions of the live stream playing all at different times within the soundtrack.

    It may have been that my MediaElement on my canvas might have been playing the stream within Blend 2 development environment? Not sure.

    Wednesday, July 18, 2007 5:00 PM
  • Tongue Tied I actually wanted to use my own custom designed player but i there were too time consuming to try to integrate with the scripts generated by Media Encoder.

    Wednesday, July 18, 2007 7:59 PM
  • So basicaly all i have in my xaml file is a media element with source set to my streaming video. What handlers do i need to implement to prevent this from happening?

    Wednesday, July 18, 2007 9:31 PM
  • I find same problem. It appears on mms:// source only by SilverLight 1.0 Beta.

    and on use Tab Browser (IE7), When playing media and close the tab, audio is playing.

    I think  destractor of mediaelement object on streaming is very buggy.Sad

     

    Another problem, On Windows Medis Streaming Server log, status is 408 by all silverlight connection.I think it's maybe near factor.

    Tuesday, July 24, 2007 9:59 AM