none
WDF KinectSensor Interface- The device cannot start. (Code 10) and No depth frames received from Kinect RRS feed

  • Question

  • I bought a system to use with a new Kinect v2 device. Unfortunately the Kinect is not recognized, and I've tried a bazillion different tacks to get it to work after reading through as many forum posts. Kinect Configuration Verifier eventually puts a red X on the last item "Verify Kinect Depth and Color Streams", and the details of that error are "No depth frames received from Kinect" and farther down "FPS: 0".

    Everything I have read indicates that this is an issue with the USB port, however the USB connection looks fine (more below).

    Help?

    DxDiag reports DirectX 11 and no issues.

    Processor: AMD FX 4130 quad-core processor (4 CPUs), 3.8GHz

    8GB RAM

    GPU NVIDIA GeForce GT 610

    Device Manager lists WDF Kinect Sensor Interface 0 with an exclamation. On the General tab of Properties the message is the generic driver error ("The device cannot start. (Code 10)").

    When I view devices by connection in Device Manager, both the WDF KinectSensor Interface 0 and Xbox NUI Sensor (presumably audio judging by the icon) show underneath:

    Renesas Electronics USB 3.0 Host Controller

           -> Renesas Electronics USB 3.0 Root Hub

                   -> Renesas Electronics USB 3.0 Hub
                               -> USB Composite Device

    I use USB Device Viewer (usbview.exe) to view details and all looks ok. I can't paste here due to size limitations but can attach to an email. Here's the first bit:

    [Port1]  :  USB Composite Device


    Device Power State:               PowerDeviceD0

           ---===>Device Information<===---
    English product name: "Xbox NUI Sensor"

    ConnectionStatus:                 
    Current Config Value:              0x01  -> Device Bus Speed: Super
    Device Address:                    0x03
    Open Pipes:                           4

              ===>Device Descriptor<===
    bLength:                           0x12
    bDescriptorType:                   0x01
    bcdUSB:                          0x0300
    bDeviceClass:                      0xEF  -> This is a Multi-interface Function Code Device
    bDeviceSubClass:                   0x02  -> This is the Common Class Sub Class
    bDeviceProtocol:                   0x01  -> This is the Interface Association Descriptor protocol
    bMaxPacketSize0:                   0x09 = (9) Bytes
    idVendor:                        0x045E = Microsoft Corporation
    idProduct:                       0x02C4
    bcdDevice:                       0x0100
    iManufacturer:                     0x01
         English (United States)  "Microsoft"
    iProduct:                          0x02
         English (United States)  "Xbox NUI Sensor"
    iSerialNumber:                     0x04
         English (United States)  "010983750247"
    bNumConfigurations:                0x01

    Wednesday, August 19, 2015 12:58 AM

All replies

  • Have you installed the Kinect SDK(v2+)? I remember that even with USB drivers from Microsoft or the USB port manufacturer didn't fix my issue. But installing the SDK helped.

    Also where is the USB port, is it on the motherboard or a PCIe USB card?
    Wednesday, August 19, 2015 11:51 AM
  • Yes I installed the SDK 2.0 from https://www.microsoft.com/en-us/download/details.aspx?id=44561

    USB 3.0 ports are on the motherboard.

    Has anybody gotten Kinect to work with the NVIDIA GT610?

    Is there a definitive step-by-step way to determine exactly what the issue is, or is there some voodoo required to set up the Kinect?


    Thursday, August 20, 2015 7:12 PM
  • One of my machines has an NVIDIA GeForce GT 640. I had to go to NVIDIA's web site to download the latest drivers before the Kinect sensor would work properly. This card is not powerful enough to get 30fps, but I can get 10-15fps, which is fine for my development needs.
    Thursday, August 20, 2015 9:18 PM
  • Thanks for the note. I upgraded the NVIDIA driver before doing anything else.

    Maybe it's time for a detailed troubleshooting manual that describes exactly how to pinpoint the issue(s) that are keeping a Kinect from working? 

    Friday, August 21, 2015 11:28 AM
  • Have you tried the troubleshooting guide below?

    https://social.msdn.microsoft.com/Forums/en-US/20dbadae-dcee-406a-b66f-a182d76cea3b/troubleshooting-and-common-issues-guide?forum=kinectv2sdk

    Friday, August 21, 2015 8:53 PM
  • Yes I've seen this. The section that applies is "Kinect Sensor not recognized by the system". I paste below the recommended troubleshooting steps. Bullets 1, 3, and 4 check out. 5 doesn't apply. 2 is a doozy.

    • Check all cables and power is connected
    • Try a different system with supported hardware configuration
    • The device should be connected directly to the on-board USB3 port on the motherboard, not an extension.
    • Check the USB3 Host controller to ensure there it is not shared with other devices
    • If using a PCI-X based card, be sure it is connected to a PCI-Express v2.0. Try PCIx x4 or x16 slots on the motherboard.

    Is there a more specific guide available anywhere that can pinpoint exactly where the issues lies? I have been all through the forums before writing my original post. Based on everything I've read, the issue has something to do with USB, but 1) I'm using a supported USB 3.0 controller, 2) I'm using a USB 3 port connected to the motherboard, 3) USB View seems to indicate that the Kinect is super speed on this port, 4) I have no other devices connected on USB 3 ports.

    Should I assume the Kinect is faulty and return it, or is there a way to find the problem?

    Sunday, August 23, 2015 4:16 AM
  • I figured I'd try on this thread, No response on my other thread. After the 1809 update, I started experiencing intermittent issues with my Kinect V2 not turning on. with my Windows 10 Pro computer. It was tolerable so I ignored the issue at that time since it was barely noticeable. Due to another issue not related It was suggested I did a fresh install of my OS using the latest version per Microsoft support. Since then it would not work at all and had to manually install the WDF KinectSensor Interface0 2.2.1811.10000 Driver. Since then I get no functionality with the camera only the sound. I've uninstalled/reinstalled the drivers/software multiple times and restarted the computer many times and get the same result I've verified all other hardware drivers are up to date and my OS is up to date. I've tried all suggestions on this thread and other threads but still get the same results. It's showing a Code 10 error with the driver. I've verified the Kinect is working properly by connecting it to my other computer and my Xbox one so I know the Kinect V2 is functioning it correctly and that it has worked on this computer until I did the fresh install of my OS.  actually, I've done two fresh installs of the OS just to make sure it wasn't an issue with the install itself and frankly another install is not an option since it takes me a couple of days to get all my software installed and computer set back up the way I need it. I know this will probably fall on deaf ears from any of the engineers that caused this issue but putting out updates with known issues as a former part of the insider programer tester myself I know Microsoft has the ability to test things out prior to pushing updates out with the ability to ensure bugs are worked out before giving everyone the update. It's a good idea but Microsoft clearly isn't using it for the initial purpose or things like this would not be happening. Leaving customers hanging wasting their time trying to do Microsofts job and fix these issues while waiting for Microsofts engineers to get around to fixing these bugs. I've noticed bugs with Windows 10 prior to the official release that has yet to be resolved. That's why I quite the insider program it was just a waste of time and the feedback was being ignored and instead of fixing issues Microsoft prefers to focus on adding more features that most don't work instead of fixing their previous bugs first. And yes, I've unplugged my USB plugs from the back of the computer and tried different ports, I also plugged other devices in to ensure the ports were working. 

    • Edited by SHoover80 Monday, March 18, 2019 7:00 AM
    Monday, March 18, 2019 6:55 AM
  • ------------------
    System Information
    ------------------

    Operating System: Windows 10 Pro 64-bit (10.0, Build 17763) (17763.rs5_release.180914-1434)
                     Language: English (Regional Setting: English)
          System Manufacturer: To be filled by O.E.M.
                 System Model: To be filled by O.E.M.
                         BIOS: 2501 (type: UEFI)
                    Processor: AMD FX(tm)-8320 Eight-Core Processor            (8 CPUs), ~4.0GHz
                       Memory: 8192MB RAM
          Available OS Memory: 8090MB RAM
                    Page File: 8332MB used, 6925MB available
                  Windows Dir: C:\WINDOWS
              DirectX Version: DirectX 12

    ------------
    DxDiag Notes
    ------------
          Display Tab 1: No problems found.
          Display Tab 2: No problems found.
          Display Tab 3: No problems found.
            Sound Tab 1: No problems found.
            Sound Tab 2: No problems found.
            Sound Tab 3: No problems found.
            Sound Tab 4: No problems found.
            Sound Tab 5: No problems found.
              Input Tab: No problems found.

    ---------------
    Display Devices
    ---------------
               Card name: NVIDIA GeForce GTX 1070

    The Kinect SDK Browser Kinect Configuration Verifier shows a red X by the Verify Kinect Depth and color Stream


    • Edited by SHoover80 Monday, March 18, 2019 7:17 AM
    Monday, March 18, 2019 7:10 AM