none
Unable to see new Premium store from Powershell

    Question

  • I am following this link to migrate an existing Azure machine over to a new premium storage account:

    https://azure.microsoft.com/en-gb/documentation/articles/storage-migration-to-premium-storage/

    I have got to the stage where I run the add-azuredisk command to define my disk as an OS disk.  However, the command fails with the message that the storage account does not exist in the subscription and it gives the subscription ID.  I have double checked through the Azure Portal GUI and the storage account does exist in the subscription.

    If I simply run the command get-azurestorageaccount it only lists my original non premium storage and does not list the new premium storage account.  I guess this is why the add-azuredisk command is failing.  So the problem to me seems that for some reason in powershell I am unable to get to the new storage account.

    I am positive I have the right subscription selected - I have even gone as far as creating an admin ID that only has access to the subscription where both storage accounts are installed.  get-azurestorageaccount still only shows me the old storage an dnot the new premium storage.

    Any help will be appreciated.

    Friday, December 4, 2015 11:40 AM

Answers

  • So I worked this out.

    The issue is if I use the new fancy Azure Portal GUI, there are "Classic" services and non classic ones.  I believe the recommendation is that new stuff should be created in the non classic.  So this is what I did for the new premium storage account.  I believe that powershell cannot see storage accounts that are created in the non classic service.  I believe this is the case since when I created another new premium storage account in the "Classic" service, I was then able to see it in powershell using the get-azurestorageaccount cmdlet. 

    Once i established this then I was able to complete the migration of my VM.

    • Marked as answer by ConfusedAgain Friday, December 4, 2015 2:13 PM
    Friday, December 4, 2015 2:13 PM