locked
VS2015 SP3 causing failure base layout folder, Illegal characters in path. After upgrade SP3. RRS feed

  • Question

  • After upgrading to SP3 for VS2015 I cannot remote debug my app. It's an ARM app only. I see others have the same issue. But no fix.

    I've updated Remote Debugger on the ARM device (Surface RT) (and my dev laptop with vs2015) and I still get:

    Severity Code Description Project File Line Suppression State
    Error  DEP4300 : Could not generate the root folder for app package 36048BaldSquirrelStudios.xxxxxxxxxxxxxxxx|VS.Release_ARM.xxxxxxx|CN=EEB5D749-xxxxxxxxxxx-57D19981601A|36048BaldSquirrelStudios.xxxxxxxxxx.Release_ARM.xxxxxxxwith base layout folder of C:\Users\xxxxxxxx\AppxLayouts. Illegal characters in path. xxxxxxxx

    This kind of junk makes development painful.

    I'm connecting to the ARM device correctly, it sees it. Pre-SP3 no problem.

    And my latest ARM only app is failing submittal due to install issues. I can install it fine but MS tester they cannot? So I thought SP3 would help.

    Thank you.


    • Edited by chrislynn Monday, July 18, 2016 10:45 PM
    Monday, July 18, 2016 10:43 PM

All replies

  • I have the same issue. I have repaired, uninstalled and reinstalled on both the desktop and the device ( like others have stated elsewhere ) and it did not help at all.

    There are very few people talking about this, and most of them are within the last few hours, or days.

    Tuesday, July 19, 2016 5:53 PM
  • I also have the same issue. I installed VS 2015 (with update 3) for the first time on a new PC on Monday, I've never had any other version of VS on here and have been getting this error whenever I connect to a remote device:

    Severity Code Description Project File Line Suppression State
    Error DEP4300 : Could not generate the root folder for app package 054cd7ba-cdba-****-******-*********|VS.Debug_AnyCPU.******|CN=817380|054cd7ba-cdba-****-******-********.Debug_AnyCPU.******* with base layout folder of C:\Users\******\AppData\Local\DevelopmentFiles. Illegal characters in path.

    My project works fine on an emulator, it's only when I connect a remote device I get this error. Also, I don't think it is the remote device because other people on my team using VS 2015 are able to connect with the device with no issue. I've ran repairs, uninstalled, reinstalled, searched on Google for answers and I've come up with nothing . 

    I should also mention that the file path doesn't have a DevelopmentFiles folder and I don't know where that came from.

    Friday, July 22, 2016 5:46 PM
  • Did you update remote debugging tools after moving to Update 3? If not, can you try updating to the latest - https://www.microsoft.com/en-us/download/details.aspx?id=48155


    Wednesday, July 27, 2016 12:16 AM
  • Did you update remote debugging tools after moving to Update 3? If not, can you try updating to the latest - https://www.microsoft.com/en-us/download/details.aspx?id=48155


    Did not solve the issue, any other suggestion? 
    I am using Raspberry Pi3 os version 10.0.14393.0

    Friday, July 29, 2016 8:05 PM
    • Edited by raV720 Monday, August 1, 2016 12:40 PM
    Monday, August 1, 2016 12:39 PM
  • No this isn't it. We've all updated tools, etc. I have SP3 and latest remote tools installed. 14.0.23309.

    My ARM device (surface RT) sees the VS dev environment and connects to it, then bails with that path error.

    To me seems like it no longer has the permission to create or something. I checked on the ARM device and that path, etc. exists.

    Friday, August 5, 2016 10:08 PM
  • I have the same problem remoting to a x86 OS and I have 14.0.23309 remote tools installed with Visual Studio 2015 v14.0.25424.00 Update 3 and .NET Framework 4.6.01586.


    • Edited by SkipFire Sunday, August 7, 2016 7:23 PM
    Sunday, August 7, 2016 7:11 PM
  • Visual Studio 2015 Update 3 is able to connect to my Surface 2 (ARM) with the RTM or Update 1 tools installed but it will not deploy resulting in the DEP4300 error. It won't let me install the ARM Update 3 tools saying "it does not work on this version of Windows". This is with a Windows 8.1 app.

    Goldfish64 - Please remember to mark any replies as answers if they help and unmark them if they provide no help.

    Sunday, August 7, 2016 8:31 PM
  • Can confirm - since there is no SP3 update package for ARM, this scenario is completely broken.
    Sunday, August 7, 2016 11:45 PM
  • This is a non-solution as the folder in your stackoverflow post does not contain install-able files.
    Sunday, August 7, 2016 11:50 PM
  • Thank goodness it's not just me. I was going crazy trying to fix this. Given the recent foul up with IoT insider builds for Raspberry Pi 3, now this, I haven't been able to get any development done for around 6 months now!! I hope the planets align soon.

    Tim Long

    Sunday, August 21, 2016 4:01 PM
  • Microsoft will you be replying? I'd like to use my surface again. Or did you completely write off the surface or ARM development using it? I've been developing with MS technologies for over 17 years now, and each year I shake my head..... Getting harder to stick up for you MS.
    Thursday, August 25, 2016 10:14 PM
  • Go to the following link and download Remote tools for VS2015 update 3, and re-install the remote tools.

    https://beta.visualstudio.com/downloads/

    I managed to get the remote debugger working.

    Tuesday, September 6, 2016 1:20 AM
  • Same problem here.

    My guess is that the tool is no longer updated for ARM.

    I went to "https://beta.visualstudio.com/downloads/" to download "Remote Tools for Visual Studio 2015 Update 3".

    For ARM, I get the following:

    For x64, I get the following:

    It has been almost two months since the initial post, we are yet to get an official response to save numerous developers from scratching their heads and wasting time on this issue.


    Hong

    Thursday, September 8, 2016 7:21 PM
  • Try getting the latest and installing again.  I had a version of Remote Tools 2015 Update 3, but they released another version of Remote Tools for Update 3 so you may see a version number change.
    Thursday, September 8, 2016 7:45 PM
  • I downloaded both (see the screenshots) at 15:00 EDT, 2016-09-08. 

    Again, the issue is for Surface RT (ARM).  The version for ARM is Update 1.


    Hong

    • Proposed as answer by Julkian Thursday, September 22, 2016 9:06 PM
    • Unproposed as answer by Julkian Thursday, September 22, 2016 9:06 PM
    Thursday, September 8, 2016 7:49 PM
  • Still nothing? I've found this problem 2 days ago working with Ionic Framework for hybrid apps. I managed to get the solution, open it and surpassing a bunch of errors i was encountering as I was nearest the deploy. Then I found this error and I'm stuck as never before... 

    Microsoft say something please :(

    Thursday, September 22, 2016 9:10 PM
  • Still no new updates.

    and to find Remote debugger for ARM is difficult now, the main search link is dead after googling.

    Dead:

    https://msdn.microsoft.com/en-us/library/y7f5zaaa.aspx

    this link is an older version not compatible with sp3:

    https://msdn.microsoft.com/en-us/library/y7f5zaaa.aspx

    What are we to do, no fixes and can't debug on surface RT anymore since SP3.


    • Edited by chrislynn Monday, October 17, 2016 12:03 AM
    Monday, October 17, 2016 12:03 AM
  • Is there still no solution for this problem on ARM devices? The original post is from July and there's still no reply from Microsoft?
    Thursday, November 17, 2016 12:45 PM
  • Add me to the list of people saying "WTF Microsoft???".  Both development machine and Surface RT have been upgraded to Release 3 as per all the previous instructions.  Rebooted all machines and am still getting the "DEP4300 : Could not generate the root folder for app package..." message.  Looks like my development for the surface is dead in the water.
    Sunday, December 18, 2016 6:56 PM
  • Same issue.  Can't deploy to our surfaces. Come on MS!!!
    Tuesday, February 7, 2017 6:05 PM
  • Same here with VS 2015 SP3 and Surface RT, any solution? Downgrade VS 2015 it Works?
    Sunday, March 5, 2017 6:51 PM