locked
Access SharePoint site outside Network/Domain RRS feed

  • Question

  • Hi

    I have created a sharepoint site with windows Authentication.

    Site URL

    http://ServerName:10015/sites/bf

    I have assigned the fixed IP to Share point server

    So when a (Internal)user wants to login to the application a popup comes where i fill the credentials and the app work just fine if present in the network/domain.

    Now if the internal user needs to access the same site from public computer  is it possible to Authenticate him as he is not  connected to Domain. I do not want to use Form Based Authentication

    And also plz suggest me how to make the application accessible outside network

    Thanks and Regards

    Wednesday, May 2, 2012 9:47 AM

Answers

  • if your computer is joined to the domain and the credential popup appears when accessing the SharePoint site, then you need to change your browser settings and add the site to your trusted zone. If the site is not recognized as a trusted site, then automatic Windows Authentication will not work.

    Dirk Van den Berghe

    Friday, May 4, 2012 6:41 AM

All replies

  • you will provide public ip then you will access anywhere
    Wednesday, May 2, 2012 10:01 AM
  • If you want to access the SharePoint site from a public computer ( read anywhere from the internet) you will need to make sure that your internet provider allows connections on the port that you site is running on ( in your case 10015 ) and preferrably have the server registered in the public DNS with a name linked to your domain ( e.g. sharepoint.yourcompany.com ) for your users to be able to find it instead of using the IP address. If you are going to use a public name or IP address ( e.g. http://10.150.25.36:10015/sites/bf ) you will need to add the URL to the Alternate Access Mappings in SharePoint or you can get an error.

    If you are accessing the site from a public computer on your internal network, then the popup for your credentials will appear also on that computer if Internet Explorer is configured to use Windows authentication. I would then suggest to add the server in your trusted zones in your browser.


    Dirk Van den Berghe

    Wednesday, May 2, 2012 10:55 AM
  • Thanks for reply

    I added the alternate access Mapping for internet like this  http://58.27.2465.245:10015/ public and internal but when iam going to access it via browser iam getting the error

    Internet Explorer cannot display the webpage

    Is there any thing need to change in IIS?

    Iam stuck on this from last day kindly help me in this regard.

    Wednesday, May 2, 2012 12:16 PM
  • the ip address you specified is invalid there can never be a number greater than 255 in the sequence.


    Dirk Van den Berghe

    Wednesday, May 2, 2012 12:23 PM
  • thanks for reply,

    i updated the Ip Address actually it was type error but  still iam not able to get it to work by alternate access mapping

    How iam adding the alternate access mapping

    Application Management > Web application > Configure Alternate access mapping > select the site >Edit public URL  and added the Ip Address

    Public URL for Zone >  http://bfeics:10015 same for internal and public and my site collection is accessible via the below link

    http://bfeics:10015/sites/bf

    Now suggest me where iam doing wrong or how can get it to work accessible via fixed IP outisde the domain.

    Regards

    Wednesday, May 2, 2012 12:37 PM
  • Actually it should work with the ip address directly.

    One of two things can happen if you try to access the site:

    1. You do not get through IIS, because the IIS bindings for the SharePoint setting are not configured for port 10015

    2. you get to SharePoint, which will write a warning in the eventlog that you are accessing the site using a url that is not defined the Alternate Access Mappings.

    If neither of above is the case, you may want to check:

    - the Windows Firewall settings of your SharePoint server and verify if port 10015 is allowed

    - check the firewall device located between you internet connection and your server to see if it allows communication on port 10015

    - check if your internet provider allows you to run servers on port 10015


    Dirk Van den Berghe

    Wednesday, May 2, 2012 12:44 PM
  • thanks for reply

    Actually issue is accessing the site outside the domain .

    So when a (Internal)user wants to login to the application a popup comes where i fill the credentials and the app work just fine if present in the network/domain.

    is it possible to Authenticate him as he is not connected to Domain.

    And also plz suggest me how to make the application accessible outside network

    In the mean time iam trying to verify the above suggested steps

    Regards

    Thursday, May 3, 2012 5:28 AM
  • if the user is not connected to the domain, the same popup should appear to request to authenticate. That user will need to have a user account in the domain that he needs to enter at that moment even though his computer is not connected to the domain.

    if you need to make the application avaialable outside of the network you will need to configure the firewall between your server and the internet to allow communication to your server over port 10015.

    A better solution would be to use a reverse proxy , such as ISA server or TMG to publish the SharePoint application to the internet. 


    Dirk Van den Berghe

    Thursday, May 3, 2012 7:09 AM
  • Thanks Dirk for your contineous help.

    Actually iam not getting the Popup when iam going to access the site from outisde the domain. iam getting the error below

    Internet Explorer can not display the webpage

    First i have to configure the site atleast it popup for credentials ( domain user name and password )

    May i allow the Anonymous access ? or  may need to change in Alternate Access mapping part ?

    Again thanks

    Regards

    Thursday, May 3, 2012 7:24 AM
  • sounds like a name resolution problem on the computer trying to access the site.

    Is that computer connected to the internet or on your internal network?

    - If internet: access the site using the ip address

    - if internal network? Is the computer using teh same DNS Server as the SharePoint server? If not, use the ip address to connect to the site.

    If you allow anonymous access then you open up the site to everybody. Maybe not what you wnat. But you can enable it temporarily to check if that allows you to access the site.


    Dirk Van den Berghe

    Thursday, May 3, 2012 7:31 AM
  • Dirk,

    Is that computer connected to the internet or on your internal network?

    yes computer from where iam accessing the site is connected to internet .

    Second iam not able to access the site using the Ip Address locally as well as externally.

    Dirk is there any issue with the Site collection URL and web application URL Mappings with the Ip Address ?

    Regards

    Thursday, May 3, 2012 9:07 AM
  • >> is there any issue with the Site collection URL and web application URL Mappings with the Ip Address . No, I do not think so

    You do not need a specific alternate access mapping defined for it to work with the ip address. SharePoint will write a warning in the log, but should return the site

    Your problem is probably related to one of the following:

    - Your internet provider is blocking the communication

    - Your internet connection router / modem is blocking the communication ( is it a router ? Can you configure it to allow communication to your SharePoint server with e.g. port forwarding or virtual server rules )

    - Your internet connection firewall is blocking the communication


    Dirk Van den Berghe

    Thursday, May 3, 2012 9:19 AM
  • Hi Dirk ,

    I just tried with Sharepoint - 80 and extend it for internet access it is working perfectly with IP Address out side the domain just PopUp for credentails and able to access the site.

    i think issue is with my site http://bfeics:10015  and when i browse this site from IIS it is not working untill and unless i give the site collection URL like this

    http://bfeics:10015/sites/bf

    first i need to access this site from IIS second is there any issue with the site collection?

    Regards

    Thursday, May 3, 2012 10:01 AM
  • >> i think issue is with my site http://bfeics:10015  and when i browse this site from IIS it is not working untill and unless i give the site collection URL like this

    http://bfeics:10015/sites/bf

    Dis you create a site coklection at the url http://bfeics:10015  in the first place? Maybe someone has deleted that specific site collection.

    As for the problem with the site on port 10015. As I  suspected, your firewall / router / internet provider is blocking traffic using that port and only allows web servers to use port 80 or 443 (SSL).


    Dirk Van den Berghe

    Thursday, May 3, 2012 10:47 AM
  • Thanks for reply Drik Van den Berghe,

    >>Did you create a site collection at the url http://bfeics:10015  in the first place? Maybe someone has deleted that specific site collection.

    Yes i created the two site collection inside the web application one was with "/" and name was Development and second was http://bfeics:10015/sites/bf and i deleted the first site collection from central Administration because of there was not the need of it and just keeped the second site collection and it is working fine locally.

    Second my firewall is configured to allow all type of ports there is no issue with the firewall i double check from the network person.

    is this issue because of deletion of first site collection from the web application? if yes then how can i get to work?

    Regards,

    Thursday, May 3, 2012 11:18 AM
  • if you deleteed the first site collection then it is normal that when you got to http://bfeics:10015/ or goto http://ipaddress:10015/ that you get nothing. You will only be able to access the second site collection using http://bfeics:10015/sites/bf or  http://ipaddress:10015/sites/bf . If you extended the web application to port 80 then you will be able to access only the second site collection at http://bfeics/sites/bf or http://ipaddress/sites/bf. Now what is your remaining issue exactly?


    Dirk Van den Berghe

    Thursday, May 3, 2012 11:22 AM
  • Thanks dirk,

    finally i able to access the site on internet by extending the web application to internet zone only final suggestion is required when ever iam accessing the site via the domain computer a Popup appear for credentails ( already system is on domain ) then why i need to enter the username and password although i used windows authentication .

    it will be true for the internet access ( out side the domain ) to pop up for credentials is there any way to prevent the User for credentails if the computer is on the same domin ?

    Regards,

    Friday, May 4, 2012 5:02 AM
  • if your computer is joined to the domain and the credential popup appears when accessing the SharePoint site, then you need to change your browser settings and add the site to your trusted zone. If the site is not recognized as a trusted site, then automatic Windows Authentication will not work.

    Dirk Van den Berghe

    Friday, May 4, 2012 6:41 AM
  • ya you can map to fixed ip
    Friday, May 4, 2012 9:33 AM
  • Hi

    I agree with Dirk but I don't think adding to trusted site is requirement for authentication. Certain javascripts on admin pages don't work without it though.

    Regards

    Yogesh

    Friday, May 4, 2012 4:11 PM