locked
Cannot access SSRS 2017 remotely RRS feed

  • Question

  • I have installed SQL 2017 Express and then SSRS 2017 on the same box. SSRS database was created on the local SQL 2017 instance. when I am on the box I dont have problems navigating to the report portal, but doing it remotely is not working. In the IE it says this:

    This page can’t be displayed
    • Make sure the web address http://boxname:8080 is correct.
    • Look for the page with your search engine.
    • Refresh the page in a few minutes.

    In Chrome it says:

    This site can’t be reached

    prismdevssrs took too long to respond.

    ERR_CONNECTION_TIMED_OUT

    Any what's wrong?

    Thanks

    Saturday, November 4, 2017 10:41 PM

Answers

  • Hi,

    Have you tried to set inbound rule to allow the portal number of your report server? If you are using 8080 portal, you could set the inbound rule from firewall settings on the report server local machine, by allowing 8080 portal. 

    Also, make sure the remote account has sufficient permission to the report server.

    Best Regards,

    Henry 

    • Marked as answer by markgoldin Monday, November 6, 2017 10:12 AM
    Monday, November 6, 2017 5:39 AM

All replies

  • It may be that the servername is not getting resolved by DNS. Can you try using the IPAddress instead?

    ie in the url you get from the reporting services configuration manager replace servername with public IP address

    I also hope you've opened relevant ports in your firewall 


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Sunday, November 5, 2017 4:55 AM
  • You need to use the URL of report manager and in place of localhost they need to use Machinename in place of LOCALHOST as

    ReportServer: http://ssrsservername/reportserver

    ReportManager: http://ssrsservername/reports

    Notes:-

    1) ssrsservername is the machine name, that you need to replace with your machine name

    2) URLs are for default instance, if you have named then instance you need to change the URL

    You need check SSRS log for more troubleshooting and also 80 port not blocked .


    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx

    Sunday, November 5, 2017 6:18 AM
  • Hi,

    Have you tried to set inbound rule to allow the portal number of your report server? If you are using 8080 portal, you could set the inbound rule from firewall settings on the report server local machine, by allowing 8080 portal. 

    Also, make sure the remote account has sufficient permission to the report server.

    Best Regards,

    Henry 

    • Marked as answer by markgoldin Monday, November 6, 2017 10:12 AM
    Monday, November 6, 2017 5:39 AM
  • Ys, there was a firewall problem. Thanks
    Monday, November 6, 2017 10:12 AM