locked
How to install .Net 4.6.2 on a server that already has 4.8 installed? RRS feed

  • Question

  • I tried and get this error: 

    a newer version is already installed and will not allow us to proceed with the installation.

    Anyone know:

    * 4.8 and 4.6.2 is it possible to install on same system

    * What or if this is even possible

    * How

    Wednesday, November 11, 2020 5:38 PM

Answers

  • Hi Chicojrman123,

    Could you tell me the specific information about your Windows Server version?

    In general, if you have installed a later version of .NET Framework 4.x(4.8), it is impossible to install an earlier version(.NET Framework 4.6.2) on a system.

    Otherwise, you uninstall the .NET Framework 4.8 and try to first install .NET Framework 4.6.2. It may cause some applications depending on the .NET Framework 4.8 to fail.

    By the way, the .NET Framework is backward compatible. If you have installed .NET Framework 4.8, I suppose it is unnecessary to install the .NET Framework 4.6.2.

    Sincerely,

    Anna


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by Chicojrman123 Thursday, November 12, 2020 9:06 PM
    Thursday, November 12, 2020 3:01 AM