locked
Help - Lightswitch Table Error RRS feed

  • Question

  • Something has happened here and i can no longer create a new table without the following error:

    Error 1 Unable to open module file 'D:\Working Documents\VISUAL STUDIO PROJECTS\RepairBusiness\RepairBusiness\Common\UserCode\Table1Item.vb': The system cannot find the file specified. D:\Working Documents\VISUAL STUDIO PROJECTS\RepairBusiness\RepairBusiness\Common\UserCode\Table1Item.vb 1 1 Common

    Can anyone please tell me what is going on?  I am somewhat of a rookie here.  My project was working fine and i was attempting to code an autoincremented alphanumeric field in a table.  Made a bunch of code attempts that i didn't entirely understand.  Probably selected some "auto corrections" somewhere that has caused a problem in the structure of my project.  Now i cannot create a new table without this type of error above.  

    Thanks!

    Saturday, November 9, 2013 8:38 PM

Answers

  • Hi,

    You may try Rebuild the Solution and it disappeared (Menu Bar -> Build ->Rebuild Solution).

    And there are two workarounds in Microsoft connect:

    In fact, we've found 2 workarounds for this problem. The first one that not always works, is to close et re-open visual studio and the solution.
    The second, that always work, is to "simulate" a change inside the project's properties (default namespace for example) and then save the project. The error is now gone.

    You can get details from here:http://connect.microsoft.com/VisualStudio/feedback/details/515041/unable-to-open-module-file-when-an-existing-solution-is-loaded


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, November 11, 2013 5:37 AM

All replies

  • It appears that i cannot even add a field to an existing (working) table.  Whatever i have done has caused serious issues with my project.  Willing to pay an expert to resolve whatever damage i have done here.  Have a lot of time into this project and don't want to start over.  Thanks-
    Saturday, November 9, 2013 9:06 PM
  • Hi,

    You may try Rebuild the Solution and it disappeared (Menu Bar -> Build ->Rebuild Solution).

    And there are two workarounds in Microsoft connect:

    In fact, we've found 2 workarounds for this problem. The first one that not always works, is to close et re-open visual studio and the solution.
    The second, that always work, is to "simulate" a change inside the project's properties (default namespace for example) and then save the project. The error is now gone.

    You can get details from here:http://connect.microsoft.com/VisualStudio/feedback/details/515041/unable-to-open-module-file-when-an-existing-solution-is-loaded


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, November 11, 2013 5:37 AM
  • Hi Yunjie,

    Can you please answer this Question ?

    Many Thanks !!!

    Monday, April 28, 2014 6:45 AM