locked
Unable to deploy/debug/register the device after updating the software to WP 7.8 on Lumia710 RRS feed

  • Question

  • My phone is developer unlocked, recently updated the phone software to WP7.8 for the Lumia710 and after that unable to deploy XAP files to the phone.

    I've a Laptop with Windows 8 Pro, Installed Visual Studio WP8 SDK + WP7.8 SDK. Zune is running and it is detecting the phone but it throws an error message saying "CONNECTION ERROR - We can't create a connection from your phone to the internet. You can still sync content between your computer and your phone."

    When trying to deploy XAP file using "Application Deployment" it says: "Error - Connecting to device failed. For connecting to Windows Phone 8 device - 0x89731810 For Windows Phone 7 device - 0x89731812"

    The device was registered earlier but when try to register using "Windows Phone Developer Registration" it says: "Unable to connect to a phone. For Windows Phone 7 phones make sure the Zune software is running and the Zune recognizes your phone. For Windows Phone 8 phones make sure that the Windows Phone IP Over USB Transport (IpOverUsbSvc) service is running."

    When trying to debug the project on device from Visual Studio it says the device is not connected.

    Please help me to fix this issue, now I'm really blocked with my app development.

    Thursday, January 31, 2013 6:07 PM

All replies

  • did you try turning the phone off and back on gin?
    Friday, February 1, 2013 12:37 AM
  • Hi, kv.vinod

    if you want to deploy your app into devices, just make sure your targeting OS on your app and on your devices is same OS. that's mean, if you build app in wp 7.1, that can't be running your app into 8.0 devices.

    Best regard

    Friday, February 1, 2013 11:21 AM
  • Ummm sir you are actually wrong... I have deployed my 7.1 app on my friends 8.0 phone I did have to register it to unlock but i was able to. You have to run your app in admin in visual studio 2012 and have the windows phone 8 app thing installed. Also you have to change up a setting in your project to allow it to deploy to the 8.0 phone as well. I have been trying to find the link i read on how to do this but have yet to find it I will update when i find it.


    Matthew Montgomery

    Tuesday, February 5, 2013 5:46 PM
  • I tried turning on and off multiple time, that never helped me. See I was able to do everything on that device prior updating to Windows Phone v7.8 ... I've checked the Zune version which is of the latest one. I'm really clueless here.
    Tuesday, February 5, 2013 6:02 PM
  • For your clarification the application tried was meant for 7.x and not for 8.x. And more over the issue here is somehow the tools (to deploy, or SDK-IDE etc) are unable to detect the device which  very much evident from the error message which I've got but Zune detect it well.
    Tuesday, February 5, 2013 6:04 PM
  • @kv.vinod - The error message at Zune which you mentioned ("CONNECTION ERROR - We can't create a connection from your phone to the internet. You can still sync content between your computer and your phone.") is most likely the reason for Device registration failure. Internet access is required in order to install few certs to unlock the device.

    Try the following:

    • Uninstall and Re-install the latest version of Zune. Try connecting the device and check if this error occurs. If not, then most likely you will be able to unlock the device.

    If above doesn't works, try switching WiFi in the device and check if internet is working on the device. Now, try unlocking the phone.

    Friday, February 8, 2013 11:32 AM
  • Tried both the methods, but unfortunately both were not working :(

    And either cases getting the below error message after connecting the phone to the PC from Zune!

    "We can't create a connection from your phone to the Internet. You can still sync content between your computer and your phone."

    I don't have a SIM card inserted into the phone, and to repeat everything works perfectly find when it was having the older Software than the 7.8 :(

    Friday, February 8, 2013 5:15 PM
  • I'm experiencing the same issue after updating a Lumia 800 to 7.8 with the NSU Pro tool. Were you ever able to register/deploy? If so, what was the fix?

    Thanks!

    Friday, March 8, 2013 8:44 PM
  • Try turning off the wifi on your phone and see if that fixes the issue.

    Kunal chowdhury has written about the similar kind of issue when deploying on windows phone 8 in the below URL

    http://www.kunal-chowdhury.com/2013/01/solution-to-resolve-windows-phone-app-deployment-issue.html


    Senthil Kumar B Twitter : @isenthil

    Saturday, March 9, 2013 2:29 PM
  • Hi Senthil,

    Thanks for you reply. I've tried this option but unfortunately it is not resolved my issues :(

    /Vinod

    Monday, March 11, 2013 2:38 AM
  • my error message is same with yours, do you have update for that?
    Wednesday, March 13, 2013 4:00 PM
  • I ended up resolving this issue by re-installing the Zune drivers over the Nokia ones. Go to device manager (in Windows) and find Nokia USB Device, then install the driver from .../program files/zune/drivers/zune

    I also had to re-register the device for development after doing this.

    Thursday, March 14, 2013 2:54 PM
  • Thanks for this tip, I did the below steps:

    Double clicked on Nokia USB Device from the Device Manager, selected the Driver tab Update Driver -> Browse my computer for driver software -> Let me pick from a list of device drivers on my computer -> Have Disk -> Entered the "C:\Program Files\Zune\Drivers\Zune" path and clicked OK then it displayed "Windows Phone USB" then pressed Next and it successfully installed the driver and replaced.

    After that too my issue is not resolved :( Do I need to restart the OS? Will be checking that now.

    Thursday, March 14, 2013 3:20 PM
  • Can you reinstall June Software?

    I can solve the same problem with reintalling Zune.

    I think that some application about other MS dev sdk was conflicted with Zune.

    Tuesday, July 23, 2013 4:53 AM
  • DiscreteDevelopment2 solution is working for me.

    • I've removed Nokia USB driver in Device Manager
    • I've also removed my lumia from Portable Device

    I can open zune without cannot connect your phone to internet issue and also register/unregister device properly.

    Friday, October 4, 2013 8:17 AM