locked
Error occur while data copy through restful service RRS feed

  • Question

  • Hi,

    I am facing an issue while copying a JSON data from rest service.

    I have tried to copy sample data as 10 JSON objects and it was successfully completed but when I tried the full copy from source then it gave the below mentioned error. I have already set the query timeout unlimited on the source, so i guess there is no issue from that side. 
    Could you please guide how to fix this issue?

    Activity denodo_plant failed: Failure happened on 'Source' side. ErrorCode=UserErrorFailToReadFromRestResource,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=Fail to read from REST resource.,Source=Microsoft.DataTransfer.ClientLibrary,''Type=System.IO.IOException,Message=The read operation failed, see inner exception.,Source=System.Net.Http,''Type=System.Net.WebException,Message=The request was aborted: The connection was closed unexpectedly.,Source=System,'

    Thanks in advance.

    Regards,

    Gohar

    Thursday, May 2, 2019 1:03 AM

All replies

  • Hello Gohar , 

    From the error it looks like that the API is not working as expected , but just to let you know that on May  02 around 1:00 PM PST we did had outages on Azure side . I am not sure if this is a fallout of that . I could have a put a retry with a good enough retry interval to see if that work .


    Thanks Himanshu

    Monday, May 6, 2019 8:55 PM