none
ReportViewer Error when Installed in the GAC RRS feed

  • Question

  • Hi,

     

    I'm building an application that has a requirement to generate PDF reports.  These reports need to be placed in a SharePoint list library.  This form generation process is kicked off using a SharePoint workflow.

     

    I created a test PDF form embedded in the workflow dll that runs in the GAC and everything worked.  For maintainability I decided to move the report code to an external DLL, built my forms and tested them using a winforms test application.  All worked great!

     

    I then hooked my reporting dll up to the workflow added everything to the GAC and it failed.  Apparently once expressions are added to a report a dynamic dll is created (possibly called by ProcessingObjectModel.dll).  This call fails and returns the error:


    Failed to load expression host assembly. Details: Could not load file or assembly 'expression_host_6c93196d662549caabdf5f7150a538d3, Version=10.7.50727.42, Culture=neutral, PublicKeyToken=null' or one of its dependencies. Failed to grant permission to execute. (Exception from HRESULT: 0x80131418)

     

    Any ideas how to overcome this issue.  The current plan is to try and move the dll out of the GAC and having the workflow start a new process via a specific path to the dll.  This would complicated an already complicated solution.

     

    Any ideas would be much appreciated.

     

    Thanks,

     

    Geordie

    Friday, November 23, 2007 10:08 PM