locked
upgrade jquery RRS feed

  • Question

  • User1024191908 posted

    I have a website which makes use of jquery.browser lots of times. It also uses many libraries(*.js) and they also use the same deprecated method. I want to upgrade my jquery version from 1.8.2 to 1.12 so I am using jquery migrate and the only error it finds is this method. how is it possible to fix all of that? thanks in advance.

    Sunday, March 4, 2018 3:59 PM

Answers

  • User-474980206 posted
    It was deprecated in 1.3 removed in 1.9. Are. You using the correct version of jQuery migrate. You should be using 1.4.1, which has support for browser. This is the version for pre 1.9 code.

    Note: after you upgrade the code to 1.9 and remove migrate, you can go to the 3.0 branch which has migrate for 1.9+/2+ to 3

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, March 4, 2018 7:31 PM