locked
Visual Studio 2013 Update 3 problem with Nuget RRS feed

  • Question

  • User-1080297099 posted

    Just installed VS 2013 update 3 today and now when I open my solution I get the following message:

    ------------------------------------------------------------------------

    The 'NugetVSEventsPackage' package did not load correctly.

    The problem may have been caused by a configuration change or by
    the installation of another extension. You can get more
    information by examining the file
    'C:\Users\...\AppData\Roaming\Microsoft\VisualStudio\12.0\ActivityLog.xml

    ---------------------------------------------------------------------------

    Here is the last entry in the event log:

    <entry>
        <record>339</record>
        <time>2014/09/14 20:44:43.398</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>End package load [NuGetVSEventsPackage]</description>
        <guid>{98BF0691-D23C-4897-A241-9CF5BEFDCC4A}</guid>
        <hr>80004005 - E_FAIL</hr>
        <errorinfo>Could not load file or assembly 'NuGet.Tools, Version=2.8.50313.46, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.</errorinfo>
      </entry>

    Has anybody else encoured this?

    I also get a message after that about some Azure Package failing.
    I'll deal with that next.

    I do see Nuget there in Tools -> Extensions and Updates.

    Sunday, September 14, 2014 4:51 PM

Answers

  • User-1080297099 posted

    Thanks,

    I just bookmarked that.

    I tried vs_ultimate.exe /uninstall /force.

    Then reinstalled from old web installer before Update 3.
    It looks like it went out and reinstalled update 3 version.
    It must just get the latest.
    Same problems after that.
    Same packages can't load.

    I just clicked Yes to always show this message for all errors and went ahead and ran the web project.
    Again I had to uninstall Nuget from package Tools -> Extensions and Updates, download the VS 2013 Nuget vsix, and install that to get rid of the Nuget error and get Package Manager stuff back.

    Everything seemed ok.

    Then I shut down and reopened VS 2013 with the solution a couple of times and the messages seemed to go away.

    I'll try the above link if these pop up again.
    It looks pretty good.

    Looking forward to 2014 now to get off of this problem:)

    Hope some of this helps others with these package problems.

    Just run your project and see if it clears up.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, September 16, 2014 7:14 AM

All replies

  • User-1080297099 posted

    Now after restoring to the point before installing Update 3, VS 2013 gives the same error messages, than says Windows is looking for  a solution, then VS 2013 shuts down.
    So now I cannot even start VS 2013.
    What now.

    Why did they do this in Update 3. What  a piece of garbage.

    Sunday, September 14, 2014 7:14 PM
  • User-1080297099 posted

    After the restore point, I ran VS 2013 repair.

    Same thing - Nuget failed to load, windows is looking for a solution.
    VS 2013 closes.

    I don't understand why Microsoft would put out such a horrible update that just breaks and destroys your whole environment.

    This is ridiculous. I can't  believe my computer is just junk now because of this.

    Sunday, September 14, 2014 10:30 PM
  • User-1080297099 posted

    No answers on this anywhere.

    Sunday, September 14, 2014 10:31 PM
  • User-1454326058 posted

    Hi smiller781,

    Please download and install NuGet manually and check the result.

    If it still has the issue, please uninstall VS and reinstall it.

    Best Regards

    Starain Chen

    Monday, September 15, 2014 5:23 AM
  • User-1080297099 posted

    Thanks,

    I uninstalled VS 2013.
    Going to try to reinstall.

    But why does the message for 2013 refer to trying to find the Nuget Package in VS 2012 pathway after VS 2013 update?

    Knowing this might help me solve my problem.

    Monday, September 15, 2014 7:12 AM
  • User-1080297099 posted

    Well I uninstalled Nuget.
    Downloaded and installed vsix for nugget and that is gone.

    But now every other package in the world is failing from scaffolding to azure.

    Right now I am working on The 'VSPackage' package did not load correctly.

    Activity log says:

    <entry>
        <record>315</record>
        <time>2014/09/15 17:32:43.190</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>CreateInstance failed for package [VSPackage]</description>
        <guid>{1A4EFADE-F6B2-4490-A2EF-21D5F3D1C8E0}</guid>
        <hr>80070002</hr>
        <errorinfo>Could not load file or assembly 'file:///C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\hjkzccc5.cqc\Microsoft.AppInsights.GettingStarted.dll' or one of its dependencies. The system cannot find the file specified.</errorinfo>
      </entry> 

    Monday, September 15, 2014 1:51 PM
  • User-1454326058 posted

    Hi smiller781,

    Please refer to this link below to deal with this issue:

    # How to unregister a visual studio package

    http://blog.spinthemoose.com/2012/12/28/how-to-unregister-a-visual-studio-package-extension/

    Best Regards

    Starain Chen

    Tuesday, September 16, 2014 1:51 AM
  • User-1080297099 posted

    Thanks,

    I just bookmarked that.

    I tried vs_ultimate.exe /uninstall /force.

    Then reinstalled from old web installer before Update 3.
    It looks like it went out and reinstalled update 3 version.
    It must just get the latest.
    Same problems after that.
    Same packages can't load.

    I just clicked Yes to always show this message for all errors and went ahead and ran the web project.
    Again I had to uninstall Nuget from package Tools -> Extensions and Updates, download the VS 2013 Nuget vsix, and install that to get rid of the Nuget error and get Package Manager stuff back.

    Everything seemed ok.

    Then I shut down and reopened VS 2013 with the solution a couple of times and the messages seemed to go away.

    I'll try the above link if these pop up again.
    It looks pretty good.

    Looking forward to 2014 now to get off of this problem:)

    Hope some of this helps others with these package problems.

    Just run your project and see if it clears up.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, September 16, 2014 7:14 AM