locked
Users Can't Remote Connect Through Remote Web Access in SBS2011 Due to STORE.EXE Size RRS feed

  • Question

  • Hello,

    Starting about a month ago, domain users have been having sporadic issuing logging into their workplace computers remotely via Remote Web Access. For a year before that there had not been any issue.

    I have finally tracked down the problem to:

    WebHost failed to process a request.

     Sender Information: System.ServiceModel.Activation.HostedHttpRequestAsyncResult/64828693

     Exception: System.ServiceModel.ServiceActivationException: The service '/Remote/BuiltIns/RDP/RemoteDesktopWebService.svc' cannot be activated due to an exception during compilation.  The exception message is: Memory gates checking failed because the free memory (1028534272 bytes) is less than 5% of total memory.  As a result, the service will not be available for incoming requests.  To resolve this, either reduce the load on the machine or adjust the value of minFreeMemoryPercentageToActivateService on the serviceHostingEnvironment config element.. ---> System.InsufficientMemoryException: Memory gates checking failed because the free memory (1028534272 bytes) is less than 5% of total memory.  As a result, the service will not be available for incoming requests.  To resolve this, either reduce the load on the machine or adjust the value of minFreeMemoryPercentageToActivateService on the serviceHostingEnvironment config element.

    The problem is I cannot figure out how to enact either solution.

    I attempted to free up physical memory by restricting STORE.EXE's max cache using the process described at eightwone's article "limiting-exchange-2010-database-cache" (sorry for the oblique reference but technet isn't letting me post a link until my account is verified) but the problem with that article is that it only covers Exchange through 2010 SP1, whereas we are running Exchanged 2010 SP2 (specifically 14.02.0347.000). This was added via Windows Update about one month ago and thus I suspect it is the proximate cause for the issue. I attempted to set the maxcache size via the linked article, setting a minimum of 131,072 (i.e. 4 gb) and a max of 262,144 (i.e. 8 gb). This is to cover 1 store with 33 users. However, despite setting those limited, and restarting the service, STORE.EXE is currently running at 14,300,000 kb with 98% physical memory used. That's 24 gb of RAM, with STORE.EXE using roughly 57% of it.

    Therefore, can someone explain either a) how to limit STORE.EXE in Exchange 2010 SP2 or explain how to "adjust the value of minFreeMemoryPercentageToActivateService on the serviceHostingEnvironment". I could not find anything how to do that in SBS 2011.

    Any help is appreciated.

    Monday, October 28, 2013 7:47 PM

All replies

  • Attempted to replicate the behavior from post /en-US/61dad4e0-26c0-46e7-9b12-e7b580f648ce post because locking a static rate would be fine for my purposes. No luck, store.exe still shot straight up to 99% physical memory usage.

    Does anyone have any ideas how I might resolve this System.ServiceModel.ServiceActivationException exception?

    Wednesday, October 30, 2013 10:59 PM
  • Brus: I do not have a solution, however I too now have this problem. We upgraded to SBS 2011 about a month ago. The problem has developed over the past week. I have yet to apply Exchange 2010 SP3 and hope to install the upgrade in a couple of weeks. FYI Store.exe is not 'off the charts' on memory like your situation. So I have experienced times where RWA/RDP did not work and then later it did without booting the server.  

    Thanks, John

    Monday, January 6, 2014 7:22 PM
  • Brus: I found this thread on the Technet site. It is not a solution/fix but rather a workaround. I have applied the modification and verified it works.

    http://social.technet.microsoft.com/Forums/en-US/bf09abb7-ad7b-4d65-a993-6fa9d53d6235/remote-access-button-stops-working-sbs-2011-standard-event-id-3-and-1309?forum=smallbusinessserver

    Thanks, John

    Wednesday, January 15, 2014 1:59 PM