locked
How is this an eval Enterprise 64 SQL 2005? RRS feed

  • Question


  • i have set up a pair of mirror, and moving to the second principle.

    I've got an strange error after running this:
    CREATE ENDPOINT [Mirroring]
    AUTHORIZATION [myDomain\userid]
    STATE=STARTED
    AS TCP (LISTENER_PORT = 5777, LISTENER_IP = ALL)
    FOR DATA_MIRRORING (ROLE = PARTNER, AUTHENTICATION = WINDOWS NEGOTIATE
    , ENCRYPTION = REQUIRED ALGORITHM RC4)

    Msg 1498, Level 16, State 2, Line 6
    Database mirroring is disabled by default. Database mirroring is currently provided for evaluation purposes only and is not to be used in production environments. To enable database mirroring for evaluation purposes, use trace flag 1400 during startup. For more information about trace flags and startup options, see SQL Server Books Online.

    when I look into the version, it is an Enterprise Edition.:
    select @@version
    Microsoft SQL Server 2005 - 9.00.1399.06 (X64)   Oct 14 2005 00:35:21   Copyright (c) 1988-2005 Microsoft Corporation  Enterprise Edition (64-bit) on Windows NT 5.2 (Build 3790: Service Pack 2)

    select serverproperty('EDITION') as edition
    Enterprise Edition (64-bit)
    Wednesday, December 2, 2009 6:32 PM

Answers

  • This is a common error & everyone is know to this error. Database mirroring is officially supported from SQL Server 2005 SP1, hence in the RTM version database mirroring is disabled by default. You can use TRACE 1400 to enable in RTM version or else update your SQL Server with latest service pack.
    Adding Trace Flag to Startup parameter

    •Goto RUN –> Type sqlservermanager.msc
    •Right click on SQL Server(instancename) service and click on properties
    •Click on Advanced tab
    •In the startup parameters enter this ;-T1400 and click on OK
    •Restart SQLservices and then try configuring db mirroring
    Or

    •Update SQL Server to latest service pack.


    Thanks, Leks
    • Marked as answer by light_wt Wednesday, December 2, 2009 8:43 PM
    Wednesday, December 2, 2009 7:19 PM
    Answerer

All replies

  • This is a common error & everyone is know to this error. Database mirroring is officially supported from SQL Server 2005 SP1, hence in the RTM version database mirroring is disabled by default. You can use TRACE 1400 to enable in RTM version or else update your SQL Server with latest service pack.
    Adding Trace Flag to Startup parameter

    •Goto RUN –> Type sqlservermanager.msc
    •Right click on SQL Server(instancename) service and click on properties
    •Click on Advanced tab
    •In the startup parameters enter this ;-T1400 and click on OK
    •Restart SQLservices and then try configuring db mirroring
    Or

    •Update SQL Server to latest service pack.


    Thanks, Leks
    • Marked as answer by light_wt Wednesday, December 2, 2009 8:43 PM
    Wednesday, December 2, 2009 7:19 PM
    Answerer
  • Thank you.

    I could almost kiss you ... almost. :)
    • Edited by light_wt Wednesday, December 2, 2009 8:48 PM Update info
    Wednesday, December 2, 2009 8:44 PM
  • I am having the same error on my local machine and i have the eval version,but it gives me a error when i write sqlservermanager.msc on RUN..
    Please Guide
    Regards
    nitin
    • Proposed as answer by Nitin1353 Thursday, December 3, 2009 1:05 PM
    Thursday, December 3, 2009 12:51 PM
  • try pressing enter
    after typing sqlservermanager.mscinto the RUN.
    Friday, December 4, 2009 2:55 PM