none
xbox one kinect on windows 10 RRS feed

  • Question

  • I know that where are multiple versions of the Kinect, but I am finding an astounding lack of specific information regarding which version of the runtime or sdk is compatible with the Kinect for XBOX One (model 1520) on Windows 10.

    I have tried SDK version 2.0, Runtime v 2.0, and Runtime v 1.7, and all give me the exact same result. 

    This device cannot start. (Code 10)

    {Operation Failed}
    The requested operation was unsuccessful.

    In addition to that, when I run Kinect v2 Configuration Verifier, I get green checks on everything except "Verify Kinect Depth and Color Streams", "Result: Not depth frames received for Kinect".

    I uninstalled all of the drivers, and installed the programs with the Kinect unplugged.  I only have this computer with usb 3.0 ports, so I can't confirm that there is no issue with the sensor.  I have Renesas Electronics USB 3.0 controller, and the Kinect for XBOX One is the only thing plugged into it.

    EDIT: The microphone on the Kinect is working, for what its worth.
    • Edited by Kebtiz Monday, November 14, 2016 3:20 AM
    Monday, November 14, 2016 3:15 AM

All replies

  • Kinect for Windows == Kinect for Xbox 360.

    Kinect for XBOX One == Kinect v2 or Kinect for Windows v2.

    So only SDK 2.0 or Runtime 2.0 are compatible with the Kinect v2 (Xbox One) sensor. SDK versions starting with 1 are for Kinect v1 sensor for Xbox 360.

    You should try to use it with a different pc. If the error message covered only depth frames and color frames are working, then its probably a sensor issue. On the other hand Windows 10 have a new driver so check to see if you have the new one or the old one. The new one breaks some SDK applications like Verifier or Kinect Studio it seems. So it might just be an incompatibility of the driver with the software. You could try to download the samples for the new UWP apps and try them out.

    Monday, November 14, 2016 8:47 AM
  • Okay, thank you, I will try to get Windows 10 reinstalled on my laptop (if Linux plays nice) and try your other suggestions as well.
    Tuesday, November 15, 2016 9:45 PM
  • Matter of fact, I faced the same problem today at work. I had a laptop sent to me yesterday with Win10 just installed on it. Installed the old SDK for Kinect, connected sensor, got Verifier's approval etc. By today, Win10 had installed numerous updates and when I tried to use the sensor, nothing. Opened Verifier, got the exact same problem with you, "No depth frames received for Kinect" and even though I had installed the SDK, I couldn't find KinectStudio at all. I immediately uninstalled the SDK and reinstalled it in hopes that it might install the old drivers as well. And it worked. It overwrote the new drivers with the old, all the while, installing KinectStudio etc. So before reinstalling Win10, try to remove the old SDK and re- install it, and then try Verifier.

    Tuesday, November 15, 2016 9:56 PM
  • Aside from clicking on it in device manager while kinect is plugged in and uninstalling it there, is there some more thorough way to ensure that the old driver(s) is(are) gone?  I have a strong suspicion that I am not wiping all of the related drivers as when I plug the kinect in I get 3 device connected beeps (I assume audio, camera, depth sensor).  I have tried reinstalling the sdk and get the same result as before.
    Tuesday, November 15, 2016 11:43 PM
  • Ha, laptop has an incompatible Intel USB 3.0 eXtensible Host controller, so that is (!) yellow, but it gives me a check on the depth and color streams.  I can run 3d builder with is on laptop, but it runs poorly, no real surprise.  But at least that confirms that the issue is with driver or controller on desktop and not the significantly more expensive toy connected to it.
    Tuesday, November 15, 2016 11:53 PM
  • Don't know man, because that yellow tick can happen even on a Intel chip :P and the laptop from yesterday got a yellow mark for USB. In fact I don't have a machine(out of 4 I've used so far that's gotten a green mark for the USB controller)

    I just uninstalled the SDK and reinstalled it while the kinect was still connected so it wouldn't try to update the driver upon reconnection of the cable,before the SDK installed its own version.

    PS: Be warned, if your vga is not good enough, the whole experience will be problematic(due to your 3d builder comment). Even if the USB is good enough and transfers data at the requested speed, the gpu is where they all end up anyway, for skeleton and depth to be calculated. If the gpu is not fast and powerful enough, the frequency with which you get frames(FPS in Verifier) will not be the 30 the SDK promises(after all the promise counts so long as you meet the recommended specs).

    Wednesday, November 16, 2016 8:51 AM
  • Okay, thank you for all your help.  Its good to know that you have had success with usb warnings, that is reassuring.  I'm not worried about performance on desktop as it has a fairly fast processor and a GTX 1070, and the laptop with a few year old i5 and integrated video was getting 30fps (struggled a bit while actually capturing but was passable).
    Wednesday, November 16, 2016 4:18 PM