none
Problems with cloning a fork from Codeplex RRS feed

  • Question

  • Hello,

    everytime when I was creating a fork (3 times now) I was having problems where cloning process was ended with this error:

    getting WebsitePanel/Sources/WebsitePanel.Providers.Virtualization.HyperVForPC/Service References/VirtualizationWebService/WebsitePanel.Providers.VirtualizationForPC.VirtualizationWebService.VirtualComputerSystemInfo.datasource
    abort: C:\ASP\WebsitePanelMods\SslCsrEmpty\WebsitePanel/Sources/WebsitePanel.Providers.Virtualization.HyperVForPC/Service References/VirtualizationWebService/WebsitePanel.Providers.VirtualizationForPC.VirtualizationWebService.VirtualComputerSystemInfo.datasource: The system cannot find the path specified
    [command returned code 255 Wed Nov 02 15:04:09 2011]

    does someone experienced similar problem with cloning a fork from codeplex?

    Regards

    Wednesday, November 2, 2011 2:07 PM

Answers

  • It looks like this is not a new issue:

    http://social.msdn.microsoft.com/Forums/en-AU/wspdev/thread/c7bed5e0-50f9-438a-b90e-0ef268aab4dd

    Maybe this is related to quite long filename (WebsitePanel.Providers.VirtualizationForPC.VirtualizationWebService.VirtualComputerSystemInfo.datasource)?

    EDIT: It looks like I found where issue is. When I created fork directory at the root of my drive everything cloned correctly. It looks like some issue with too long path for this file.
    • Edited by Webio Thursday, November 3, 2011 9:14 AM
    • Marked as answer by Webio Sunday, November 6, 2011 10:23 AM
    Thursday, November 3, 2011 9:03 AM

All replies

  • It looks like this is not a new issue:

    http://social.msdn.microsoft.com/Forums/en-AU/wspdev/thread/c7bed5e0-50f9-438a-b90e-0ef268aab4dd

    Maybe this is related to quite long filename (WebsitePanel.Providers.VirtualizationForPC.VirtualizationWebService.VirtualComputerSystemInfo.datasource)?

    EDIT: It looks like I found where issue is. When I created fork directory at the root of my drive everything cloned correctly. It looks like some issue with too long path for this file.
    • Edited by Webio Thursday, November 3, 2011 9:14 AM
    • Marked as answer by Webio Sunday, November 6, 2011 10:23 AM
    Thursday, November 3, 2011 9:03 AM
  • Hi there,

    Your guess is absolutely correct. It's the issue with oversized path + file name. I do prefer the following folders schema to work with Codeplex:

    C:\Codeplex or C:\CP

    then a project name follows:

    C:\Codeplex\WebsitePanel

    afterwards a fork name or trunk follows:

    C:\Codeplex\WebsitePanel\default or C:\Codeplex\WebsitePanel\<fork_name>

    This helps me to easily recognize forks and trunk, changes have been made and etc.

    And you can always shorten it if it does not fit into path length limits.

    Happy coding!


    Please vote, if you find a post helpful! Appreciate.


    Friday, November 4, 2011 7:32 AM
  • Only issue is that I dont use my root C: for anything... I have a special path for all my VS projects etc.
    Tuesday, November 15, 2011 3:34 AM
  • Only issue is that I dont use my root C: for anything... I have a special path for all my VS projects etc.


    That is not a problem at all. :) The general idea is to keep as short path to the project's folder as possible.


    Please vote, if you find a post helpful! Appreciate.
    Tuesday, November 15, 2011 5:08 PM