locked
error on webhttp sendport RRS feed

  • Question

  • Hi,

    i have the following error only this afternoon when calling a saas API from a send port using the WebHttp adapter :

    This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Authentication failed because the remote party has closed the transport stream.

    someone has already faced this problem?I'm using Biztalk 2016 with CU5

    Thursday, August 30, 2018 3:48 PM

All replies

  • Hi,

    It looks there has been some changes happen from your SaaS API, at high level it looks earlier it was expecting the TLS 1.0 and now no more(Refer Link#1).

    BizTalk by default passes the TLS 1.0 and if endpoint request denies TLS 1.0 it will try to send the same request with SSL 3.0 which should not be passing in your case.

    i would recommend you to try with WCF-Custom adapter once, and check if you were able to resolve this error.

    Link#1 http://geekswithblogs.net/gvdmaaden/archive/2010/10/04/tls-1.0-and-ssl3-woes-in-biztalk-wcf-send-port.aspx

    HTH


    Hope this Helps!!!! Regards, Note: Please Mark As Answered if you satisfy with Reply.

    Friday, August 31, 2018 10:12 AM
  • If it is the TLS 1.2 issue (which is quite likely) then you need follow the steps in Support for TLS 1.2 protocol in BizTalk Server

    1) The SQL Server 2012 Native Client version 11 should be installed on all BizTalk Server systems

    2) Install the latest CU / FP for your BizTalk server 

    3) As per the linked "3155464 MS16-065: Description of the TLS/SSL protocol information disclosure vulnerability (CVE-2016-0149): May 10, 2016" set the SchUseStrongCrypto Registry key





    Sunday, September 2, 2018 9:29 PM