locked
Problem with Report RRS feed

  • Question

  • User-740453238 posted

    I have a local report in VS 2010.  ON that form I have a Tablix box.  In that box I have 2 images that I either turn on or off depending on a certain field.  The visibility expression of the image box is telling me that the Report item not linked to a dataset.  I have tried using the Datasets button there as well but the actual field is underlined in Red and says its not valid.

    The visibility button of the Tablix box works fine, but not the image inside this and the dataset name is set here, but there is no option to set the datset name of the image box.

    Can someone help me figure out own to make this work.  This worked fine in VS 2005

    Here is my If Statement:  =iif(Fields!CEOOK.Value="True",False,True).  The fields!CEOOK.value is underlined in red and says not valid in scope (Or something like that).

    Wednesday, January 16, 2013 3:57 PM

All replies

  • User-1528094326 posted

    Easy question first, are you sure that the images are children inside the Tablix box and not just using margins to hover over the top of it?

    Wednesday, January 16, 2013 6:25 PM
  • User-740453238 posted

    I tested that and if I delete the tablix box the image goes away to.  So I'm sure it's a part of it.  Could always be wrong though.

     

    Wednesday, January 16, 2013 10:00 PM
  • User-740453238 posted

    Does anyone have any ideals on this. There has been no replys.

     

    Mike

    Saturday, January 26, 2013 5:08 PM
  • User-1528094326 posted

    I'll do a test of my own shortly here. Do you have anything special that I should know about? I'm going to tie a custom test class to a tablix and then drop a couple images and make them show or hide based on those values.

    Monday, January 28, 2013 4:07 PM
  • User-740453238 posted

    Thanks for any help you can give.  I'm not sure what is happening, but I really need to figure this out.

    Tuesday, January 29, 2013 10:08 PM
  • User1208822301 posted

    Is the image coming from a local file/folder or is it coming from a query to the database?

    Thursday, January 31, 2013 8:58 PM