locked
web.config configsource parent conflict RRS feed

  • Question

  • User-125636336 posted

    I could not find any explanations of this error issue online, but was able to figure it out on my own. I am posting this thread so that google might pick it up and from now on if someone searches for "The configSource file" and/or "is also used in a parent, this is not allowed" then at least this thread might help them

    ********************************

     

    I am getting the error:

    The configSource file 'web_appsettings.config' is also used in a parent, this is not allowed.

     

    Line 10: 
    Line 11:   
    Line 12:   <appSettings configSource="web_appsettings.config"></appSettings>
    Line 13: 	<connectionStrings configSource="web_database.config"></connectionStrings>
    Line 14: 	<system.web>
     

    and part of my web.config file looks like this:

     

    1    <!--l version="1.0-->
    2    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
    3      <configSections>
    4        <sectionGroup name="microsoft.web" type="Microsoft.Web.Configuration.MicrosoftWebSectionGroup">
    5          <section name="converters" type="Microsoft.Web.Configuration.ConvertersSection" requirePermission="false" />
    6          <section name="webServices" type="Microsoft.Web.Configuration.WebServicesSection" requirePermission="false" />
    7          <section name="authenticationService" type="Microsoft.Web.Configuration.AuthenticationServiceSection" requirePermission="false" />
    8          <section name="profileService" type="Microsoft.Web.Configuration.ProfileServiceSection" requirePermission="false" />
    9        </sectionGroup>
    10     </configSections>
    11   
    12     <appSettings configSource="web_appsettings.config"></appSettings>
    

     

     

    REASON:

     the above scenario is such that I was accessing  http://localhost/MyProject/  ... the error stemmed from  http://localhost/ also mapping to the exact same location as http://localhost/MyProject/ , thereby causing localhost (the "parent") to be using the same configSource location as its child MyProject.  when I accessed http://localhost/MyProject/ , it caused this error. but when going to http://localhost/ everything works just fine

     

    Monday, October 16, 2006 6:12 PM

All replies

  • User-488692329 posted

    You're a star. I'd moved my website into a seperate website and started developing from there. I hadn't redirected the localhost back to inetpub and ended up with localhost and www.mydomain.com pointing at the website. This gave me all sorts of errors, stopping intellisense and debugging working properly amongst other things.

     Having changed localhost back to pointing at inetpub and leaving my project pointing at www.mydomain.com, everything is now working great again in my project.

     

    Thanks for the tip

    Monday, October 1, 2007 9:02 AM
  • User1677479917 posted

    Guys,

    Sorry, tried to understand this stuff on my own. But unfortunately. can't do it!

    Can anyone please help us to understand this?

    Basically, we've one website - with a hostname let's say www.abc.com - Now when we access it using www.abc.com/%20/ it gives us this error:

    Enabled FRT, and after disabling all modules, found error in IIS Web Core -- and following error messages looks suspicious. Can you please share your expert views on this? FYI - We don't have any virtual directory. And Default WebSite is stopped -- Already tried this -- http://beweb.pbworks.com/w/page/5533126/ASP_NET%20Error%20Messages

    FILE_CACHE_ACCESS_START
    FileName="E:\SVN-Projects\sourcecode\Website\ \", UserName="IUSR", DomainName="NT AUTHORITY"
    15:08:11.452
    ModuleName="IIS Web Core", Notification="MAP_REQUEST_HANDLER", HttpStatus="404", HttpReason="Not Found", HttpSubStatus="0", ErrorCode="The system cannot find the file specified.
     (0x80070002)", ConfigExceptionInfo=""
    Wednesday, September 11, 2013 11:15 AM