none
BizTalk -Covast Pipeline issue RRS feed

  • Question

  • Hello All

    We are migrating from BizTalk 2013R2 to 2016. Covast accelerator is working fine in 2013 . However Covast accelerator 2016 is installed successfully on BT 2016 plateform. However while processing an edi message we are getting an error.

    A message received by adapter "FILE" on receive location "RcvLocEdi" with URI "C:\TestEDI\Input\*.edi" is suspended.

     Error details: There was a failure executing the receive pipeline: "Covast.BizTalk.Pipeline.EDI.CovastEDIReceivePipeline, Covast.BizTalk.Pipeline.EDI.Default, Version=5.0.0.0, Culture=neutral, PublicKeyToken=68bef120a46b49ad" Source: "Covast EDI Disassembler" Receive Port: "EDITest" URI: "C:\TestEDI\Input\*.edi" Reason: Could not load file or assembly 'Covast.BizTalk.Pipeline.EDI.Interop.dll' or one of its dependencies. The specified module could not be found. 
     MessageId:  {267336FE-44F3-4FEE-A497-314A2B8EBA73}
     InstanceID: {7D38A4E4-867F-4DAD-A941-D8E75AF31FFF}

    I tried all approach gacing dll. but nothing working can someone suggest what can be the root cause.

    Thanks 

    Anagh Bhatt


    anagh

    Thursday, June 21, 2018 10:16 AM

All replies

  • Hi,

    You should probably ask the 3:rd party supplier. In this case, Covast.

    Open a Support Case @ the Covast web site.

    Br,

    Leo


    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    Thursday, June 21, 2018 10:34 AM
  • Thanks we have raised the request with covast

    anagh

    Thursday, June 21, 2018 11:24 AM
  • Well, why are you using Covast?  That was replaced over 10 years ago.

    So far as I know, it has not been updated since version 2006.

    Thursday, June 21, 2018 4:34 PM
  • Microsoft bought the rights from Covast and built native support for EDI in BizTalk 2006 R2 onwards

    Do you have any specific requirement or reason to use the Covast adapter in BTS 2016?

    /Peter

    Thursday, June 21, 2018 9:09 PM
  • Thanks

    We have specific requirements. And contract with Covast


    anagh

    Friday, June 22, 2018 6:34 AM
  • Thanks everyone issue is resolved

    anagh

    Wednesday, July 4, 2018 6:29 AM
  • If you share these requirements, we can help you implement them.  There is no scenario where BizTalk EDI cannot replace Covast.
    Wednesday, July 4, 2018 11:20 AM