none
Change DNS after adding VMs to Virtual Network RRS feed

  • Question

  • Hello, 

    When I created my Virtual Network I had to pre populate the DNS settings.  I set my primary DNS to my x.x.x.4 and my secondary to x.x.x.5.  When I added the VMs, my primary received x.x.x.4 but my secondary received x.x.x.12.   

    I have seen other threads that have been accepted with the answer of this feature will be coming soon.   Has there been any progress in the ability to change the DNS settings without needing to recreate the Virtual Network?   I have tried with the UI and in powershell and it seems like the answer will still be no, but I figured I would still ask.   

    Is there a work around until there is the ability?

    Thanks!

    Tim  

    Friday, April 12, 2013 3:34 AM

Answers

All replies

  • I have found a work around .. it is kind of a pain but I did want to share.  I was able to use powershell to remove my VMs and delete the cloud service.  I then could create the cloud service specifying the correct and re add my VMs.    

    I am still documenting the process and IO will share the powershell code once I have finished.  

    - Tim 

    Monday, April 15, 2013 7:28 PM
    • Marked as answer by Tim Benham Tuesday, April 16, 2013 4:46 PM
    Tuesday, April 16, 2013 4:46 PM
  • Open windows Azure Powershell and execute:

    Get-AzureVNetConfig -ExportToFile C:\azure.netcfg

    open azure.netcfg with notepad, locate your DNS settings, change it and import

    Set-AzureVNetConfig -ConfigurationPath C:\azure.netcfg

    login to your VM and renew ip settings

    for Windows machines open elevated command prompt and run command "ipconfig /release && ipconfig /renew"

    worked for me


    Thursday, April 25, 2013 1:34 PM
  • Scripting_Guy,

    I tired that about a month ago and it failed running the Set-AzureVnetConfig saying the network was in use and it could not be modified.  

    I can try it again, but when you ran it did you not have any issues?  

    Tim 

    Tuesday, April 30, 2013 4:28 PM