locked
Referencing Oracle.DataAccess in the project giving error RRS feed

  • Question

  • User-725020093 posted

    Hi,

     I am installing ODP.net on the client and server machines to support the new ODP.net data provider provided by Oracle for .net 4 and above. Lately I have been facing issues in the Oracle.DataAccess reference in my project. I have installed the ODAC installer on my machine and the assembly version is not visible in the GAC. I tried running my project and its throwing a strange error Could not find or failed to load Oracle.DataAcess.....Version......,after adding the reference manually using the dlls in the XCopy downloads file. I tried to add reference from the GAC to older version(2.121.1.0).But I still get the same error no matter which version I use. I created a small sample program and used Oracle.DataAccess in that and it seems to be working fine. Can any one help me sort this issue.

    Thanks

    Monday, October 26, 2015 3:43 PM

Answers

  • User-725020093 posted

    Hi thanks 

      I figured out that visual studio 2010 WebDev.WebServer.exe is 32-bit so I was getting this error and was breaking my head. My app was running in 64 bit iis but waas not able  to run from VS.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, November 28, 2015 8:02 PM

All replies