locked
Why does my App Icon not show up? RRS feed

  • Question

  • User73413 posted

    Hello guys,

    I just want to know if anyone else ran into this issue.

    On Xamarin.IOS i am trying to deploy an App to the app store, but whatever i do, the AppIcon does not get deployed, neither in Debug, nor in Release mode. I tried hardcoding the Icon - Files in the Info.Plist. I also tried the normal way using Image assets, i checked all the sizes again, i even tried building the Info.plist and the image asset folder in Xcode and import it, but whatever i do, the app icon doesn't appear to be present in the app bundle. Build action is set to ImageAsset.

    Can anyone help?

    Thank you

    Thursday, August 13, 2015 1:02 PM

All replies

  • User31231 posted

    Hi @StephanSchmidt,

    Try the following:

    1. Remove the app from the iOS device that you are testing on.
    2. Delete the bin and obj files from your Xamarin.iOS project.
    3. Ensure that all of you icon files are in place (either via the info.pst file or an Image asset).
    4. Do a rebuild and re-install.

    Hope this helps,

    Kevin

    Thursday, August 13, 2015 1:43 PM
  • User73413 posted

    Hi,

    thanks a lot for your answer, but we already tried the steps that you listed. We tried it again now but with no luck. The Info.plist as well as the image asset is in place, and the info.plist points towards AppIcons.appiconset. I also checked the csproj File, everything seems to be alright there as well, except that each app icon file is pointed to twice. (See the code i posted below) Could this cause any trouble? Please if someone can help it would be great, we are really running out of options here and need to deploy soon.

    <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Contents.json" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-60%402x.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-60%403x.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-72.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-72%402x.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-76.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-76%402x.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-Small-40.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-Small-40%402x.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-Small-40%403x.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-Small-50.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-Small-50%402x.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-Small.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-Small%402x.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon-Small%403x.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon.png" />
        <ImageAsset Include="..\ahk_app_ios\Resources\images.xcassets\AppIcons.appiconset\Icon%402x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Contents.json" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-60%402x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-60%403x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-72.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-72%402x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-76.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-76%402x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-Small-40.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-Small-40%402x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-Small-40%403x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-Small-50.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-Small-50%402x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-Small.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-Small%402x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon-Small%403x.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon.png" />
        <ImageAsset Include="Resources\Images.xcassets\AppIcons.appiconset\Icon%402x.png" />
    
    Friday, August 14, 2015 7:25 AM
  • User73413 posted

    After a few more hours wasted i decided to create a completely new project and add all the files again. That solved the issue.

    Monday, August 17, 2015 8:17 AM
  • User171047 posted

    I had the same issue. Solved it by disable readonly mode from images (readonly mode provides TFS) and reopen plist editor.

    Tuesday, December 29, 2015 4:34 PM
  • User4183 posted

    Xamarin has major problem with creating packages. I have seen this behavior time and time again with icons, splash screens, sounds and so on. Basically you can do what is mentioned above or you can sit there and keep cleaning, rebuilding, restarting the environment and hope the thing actually starts working. This has been a very frustrating experience that they do not fix. I have had multiple support tickets in over the years to resolve these issues, yet they keep coming up. Basically, if you can't create a project that proves the problem to them, it will never get fixed.

    Tuesday, February 23, 2016 1:45 PM
  • User158028 posted

    Hello all, I've been plagued by this issue. I had to recreate an app once just to get things to work. After a while now the icon does not show up. I would have to go through that pain again just to get things working. I even went back a few builds to when it was working and still no luck.

    I have attempted to clean my workspace (entire TFS workspace) and reget all and still no luck. I am using VS 2015 and xamarin iOS.

    Can someone please help me resolve this. Nothing has changed in the icons and the iconset.

    Saturday, August 6, 2016 3:42 AM
  • User158028 posted

    For anyone that hits this issue, just found a hack that works. I spent a couple hours digging into the Visual Studio diagnostic logs and comparing against a new application that builds properly.

    I realized some inconsistency in the parameters passed to the actool and went digging into the Mac because I saw a folder that's being managed on my mac that's under Library/Caches/Xamarin. I cleared it as it had folders for all projects i've ever built and assuming that it really is a cache it should be rebuilt if it doesn't exist. I rebuilt and my icons got processed properly.

    The folder is: /Users//Library/Caches/Xamarin/mtbs/builds/

    This worked for me. I don't know if it will work for all but worth a shot. Seems Xamarin get's it's tentacles tangled after a while developing against the same Mac Build agent and the same VS project.

    NOTE: The "Library" folder on the mac does not show up by default. Under the "" folder right click and select "Show view options", then check the box to "show Library folder."

    Goodluck!

    Saturday, August 6, 2016 5:28 PM
  • User158028 posted

    For anyone else hitting this issue, I just found a hack that resolves this. I ran and compared build logs (diagnostic) in VS2015, problem project vs. new project that icons worked fine. Saw some inconsistencies in the actool task that sent me to my Mac to investigate.

    I found a caches folder that was involved in the inconsistency and figured if i cleared it that i may make headway. I cleared the cache and the icons built properly.

    The cache path is here: /Users/-YourUserName/Library/Caches/Xamarin/mtbs/builds/-YourProjectName-

    Note the "Library" Folder does not show up by default on a mac. Go to your username folder, right click and select "Show view options" then check "Show Library Folder"

    Goodluck

    Saturday, August 6, 2016 5:40 PM
  • User332541 posted

    Not sure if anyone is still experiencing this issue, but simply replacing the icons in Assets.xcassets worked for me.

    Saturday, June 24, 2017 3:07 AM
  • User221588 posted

    Hi all, had to roll my head for a full day by trying out many suggestions. Finally got to work by removing and recreating "Images" Asset Catalog. Steps: 1. Take backup for "Images.xcassets" folder with all AppIcons. 2. Right Click and Delete "Images" Asset Catalog from Solution Explorer. 3. Right Click and Delete "Images.xcassets" under "Resources" from Solution Explorer. 4. Right Click "Asset Catalogs" and Add Asset Catalog "Images" from Solution Explorer. 5. Now open this new "Images" Asset Catalog and add required AppIcon images manually. 6. Reload/Refresh the solution explorer, you can see "Images.xcassets" under Resources folder. Include in the project. 7. Clean and Rebuild Solution. if required, delete the app in simulator/device and run. 8. Open Info.plist designer and under "Visual Assets" tab, Choose "AppIcons" source in App Icons. App Icon will appear.

    Friday, August 18, 2017 7:13 AM
  • User16951 posted

    +1 to @MahibaRajaseelan answer. Renaming AppIcons to AppIcon did the job. Guess, the caching is the reason as other people mentioned above.

    Tuesday, September 12, 2017 1:42 PM
  • User221588 posted

    @AlexS - Yes, Thanks. It should be caching. Re-doing or recreating the folder,images and AppIcons inside Asset Catelogs is working out.

    Wednesday, September 13, 2017 5:26 AM
  • User355819 posted

    In case it helps someone in need. Clear cache didn't work for me, but remove & re-add images worked for me. My case it was tab icons didn't show up. I backed up the Resources folder, then removed affected images from it, then re-add images back, and everything seems to work as they supposed to for now. Xamarin needs to fix these issues. I had different issues dealing with images & app icons a number of times.

    Thursday, November 30, 2017 10:56 PM
  • User283173 posted

    I know I'm way late to this party, but I wanted to fill you in, "you" being anyone interested, in how I resolved the issue.

    I had migrated a PCL project to .NET Standard by creating a new Solution and simply copying the files over, including the Info.plist. I then created and recreated a Media Asset Catalog over and over without resolving the issue; still no icon.

    I finally looked in the Info.plist and discovered that while the name of the Asset Catalog had changed, it was still pointing to the location from the previous Project. Apparently, Asset Catalogs were stored in the Resources folder and with my new Project, they were created directly in the root of the Project directory. I removed the extra "Resources" path in the directory structure referred to in XSAppIconAssets string tag and voila, my icons were back.

    Personally, I'd call this a bug; that directory string should be accurately-formed, regardless of whether you copied it from a previous project.

    Thursday, March 29, 2018 6:50 PM
  • User35290 posted

    @BruceFullwood Thank you very much, this worked for me!!

    Thursday, April 12, 2018 9:20 AM
  • User256403 posted

    i have the same problem and non of these solution resolved my problem

    Thursday, April 19, 2018 1:56 AM
  • User366697 posted

    I have the same problem in xamarin.ios native app. Can someone please help me to resolve this?

    Friday, April 20, 2018 10:22 AM
  • User359075 posted

    I fixed that problem following this steps: 1- Check the folder path for my assets (In my case, it was "[Project]/Media.xcassets/AppIcons.appiconset" 2- Open Info.plist file with notepad or other text editor 3- Search for "XSAppIconAssets" key 4- The value for this key was wrong, It was pointing to "[Project]/Resources/Media.xcassets/AppIcons.appiconset" After update this value, clean and rebuild the project and should work.

    Friday, April 20, 2018 2:13 PM
  • User311734 posted

    @BruceFullwood Thanks! That saved me :smile:

    Tuesday, April 24, 2018 1:27 PM
  • User199554 posted

    @maurogarcia0209 Thank u , it was done :smile:

    Friday, April 27, 2018 12:15 PM
  • User337646 posted

    @maurogarcia0209 said: I fixed that problem following this steps: 1- Check the folder path for my assets (In my case, it was "[Project]/Media.xcassets/AppIcons.appiconset" 2- Open Info.plist file with notepad or other text editor 3- Search for "XSAppIconAssets" key 4- The value for this key was wrong, It was pointing to "[Project]/Resources/Media.xcassets/AppIcons.appiconset" After update this value, clean and rebuild the project and should work.

    That was my problem, XSAppIconAssets and also XSLaunchImageAssets where wrong

    Thursday, May 3, 2018 12:43 PM
  • User313353 posted

    Same here XSAppIconAssets and XSLaunchImageAssets where wrong in the plist file

    Thursday, May 10, 2018 3:00 PM
  • User366651 posted

    @maurogarcia0209 solution worked for me too, thanks :smiley:

    Thursday, May 17, 2018 10:23 AM
  • User242253 posted

    @maurogarcia0209 ! You are the king. It works

    Why does this happens, and takes so much time from our developers?

    Thursday, May 17, 2018 7:33 PM
  • User256341 posted

    thank you @maurogarcia0209 saved me!

    Tuesday, June 5, 2018 10:12 AM
  • User44072 posted

    Thanks so much @BruceFullwood finally I could see the icons after a day of work, this obviously is a bug!, I changed the images after apply the Bruce advise and the .plist file took the Resources folder again then I had to change again "manually".

    Wednesday, June 6, 2018 3:25 AM
  • User342235 posted

    @maurogarcia0209 said: I fixed that problem following this steps: 1- Check the folder path for my assets (In my case, it was "[Project]/Media.xcassets/AppIcons.appiconset" 2- Open Info.plist file with notepad or other text editor 3- Search for "XSAppIconAssets" key 4- The value for this key was wrong, It was pointing to "[Project]/Resources/Media.xcassets/AppIcons.appiconset" After update this value, clean and rebuild the project and should work.

    Thanks, That worked for me.

    Friday, July 27, 2018 1:12 PM
  • User328941 posted

    I know this is basic but make sure the *AppIcon *setting has not been changed. I have had the android team overwrite my plist with a non setting more than once in git.

    Friday, March 22, 2019 4:49 PM
  • User313403 posted

    @maurogarcia0209

    I have tried the same steps you mentioned.

    In the info.plist (Source) XSAppIconAssets Assets.xcassets/AppIcon.appiconset and in the info.plist (Application)

    Wednesday, June 12, 2019 7:03 PM