How to Re-install my Access Add-in RRS feed

  • Question

  • I have a small Access Add-in (.mda) that I use to automate some of my development tasks. I've been using it for many years.

    Since this week's Windows 10 update, I can no longer install it.
    Running as Administrator when I go to Database Tools > Add-Ins, it is listed in Available Add-ins. However, when I click install, I receive the message 'You do not have sufficient security permission to install this Add-in. Contact your system administrator for assistance.'
    Same thing if I click 'Add New...'.

    I am running O365 Access Version 2005 (Build 12827.20336 Click-to-Run) Current Channel.

    Any ideas on how I can install my add-in?
    Instructions on manually creating the registry entries?

    • Edited by Alphonse G Friday, June 19, 2020 1:33 PM
    Friday, June 19, 2020 1:18 PM

All replies

  • Simply install the program in a folder where the user has full permission to read and write.

    For our products released in the last few years, when you install it for your individual use (does not apply when you install it for the entire machine), the setup program automatically selects a folder in your Users folder. This ensures you have the rights necessary to run the program. If you install it for the machine, it defaults to a folder name in the C:\ root folder.

    You can overwrite this folder and install it anywhere. Some people with Administrator rights have chosen to install it in their C:\Program Files folder. You may think you have WRITE rights because you can successfully install the program in that folder. However, even with Administrator rights, this won't work unless you explicitly go into Windows and modify the User Access Control rights on that folder after installation. We don't recommend you do that just to run Microsoft Access add-ins and databases.
    Friday, June 19, 2020 3:33 PM
  • Thanks for the reply. I do have full explicit permissions on the folder.
    There is no installation/setup involved or needed. This is my own add-in on my own machine that I only use for development. The 'Install' is via Access' Add-in Manager.
    Friday, June 19, 2020 4:26 PM
  • Have you tried reverting your build to a prior build number to see if the issue lies in a recent update?  You may have to go back a few build, just to see.

    You may like to review:


    Daniel Pineault, 2010-2019 Microsoft MVP
    Professional Support: http://www.cardaconsultants.com
    MS Access Tips and Code Samples: http://www.devhut.net

    Friday, June 19, 2020 4:57 PM
  • Thanks Daniel.

    I haven't tried that for a couple of reasons.
    The O365 update was last week and it was working then. I'm pretty sure it has to do with this week's Windows update.
    I also have an open ticket with Microsoft support on another issue (going in circles for the past month), that is dependent on the build.

    I was hoping someone could point me to instructions to manually create the necessary registry entries.

    Friday, June 19, 2020 5:53 PM
  • Alphonse G,

    I have been experiencing the same issue.  I came across the article below from 2010.  I found that the solution for me was the same as this one.  Basically the registry entries are case sensitive.  'Menu Add-ins' vs. 'Menu Add-Ins' in the USysRegInfo table.  Once I changed that all of my add-ins..... excuse me.... Add-Ins were now able to install.


    • Edited by ChrisInUT Saturday, July 25, 2020 8:28 PM
    Saturday, July 25, 2020 8:27 PM
  • Thanks for the info. Very interesting. My casing was already correct. What I ended up doing is installing on another machine, finding the registry entries and exporting them.
    Now, whenever, Access decides to uninstall my add-in, I simply run the reg files and all is good again.

    Saturday, July 25, 2020 9:53 PM