locked
Debugging symbols (TC4.4.1) and ASP.NET RRS feed

  • Question

  • Hello,

     

    Our application is a WEB-server written on ASP.NET.

    I am trying to reproduce the TC4.4.1 steps and encountered some problems... First things first.

    1. We have included the .pdb symbol files for all application's binaries into the installer.
    2. After a successfull installation and first launch of the application, I tried to launch WinDbg from the Certification Tool. It does not see the w3wp.exe (the IIS worker process), since it is a system process.
    3. Okay, I launched it manually, with elevation, and attached to w3wp. But now the debugger shows "ERROR: Symbol file could not be found" message, hence the test is failed.
    4. Setting the "File->Symbol File Path..." option to a proper folder path didn't help.

    Is it possible to use WinDbg to debug ASP.NET apps? What should we do to complete this test case?

     

    I need help... Thank you in advance.

     

    Vitaly.

    Monday, October 29, 2007 3:44 PM

All replies

  • Hi all,

     

    I am facing the same issues too. Any help would be great as well !!

     

    Thanks

     

    Monday, October 29, 2007 10:20 PM
  • Hello Vitaly Brusentsev

     

    There is extensive help in the debugger documentation on dealing with symbols problems. 

    Please read them and also look specifically at the “!sym noisy” command.

     

    Some more information on this is available on the KB article here http://support.microsoft.com/kb/892277

     

    Let us know if that helps you thru the debugging steps.

     

    Thanks,

    [Venkat] | Windows Server Logo

    www.InnovateOnWindowsServer.com

    Tuesday, October 30, 2007 1:36 AM