locked
ReportViewer Control shows no data RRS feed

  • Question

  • User750757947 posted

    [Mod: edited to mask password]

    Hey everybody

    I've created a aspx page containing a ReportViewer Control. The Report I want to display is located on another server which has the SSRS tools installed. I can show all the reports on the browser, if I request them directly (http://myReportserver/reportserver). But when I use the control, no data is being displayed, the empty report itself is being displayed though.

    Here's my code so far:

    Markup

    <form id="form1" runat="server">
            <asp:ScriptManager ID="ScriptManager1" runat="server"></asp:ScriptManager>
        <div>
            <rsweb:ReportViewer ID="ReportViewer1" runat="server" Font-Names="Verdana" Font-Size="8pt" ProcessingMode="Remote" WaitMessageFont-Names="Verdana" WaitMessageFont-Size="14pt" Height="1060px" Width="1015px" AsyncRendering="False">
                <ServerReport ReportPath="/XyzReporting/Report01" ReportServerUrl="http://myReportserver/reportserver" />
            </rsweb:ReportViewer>
        </div>
        </form>

    Code Behind (for Authentication)

    public partial class WebForm1 : System.Web.UI.Page
        {
            protected void Page_Load(object sender, EventArgs e)
            {
    
                ReportViewer1.ServerReport.ReportServerCredentials = new ReportServerCredentials("Administrator", "xxxx", "myreportserver");
    
            }
    
        }

    Any help would be appreciated.

    Thanks a lot,

    Ronin

    Thursday, August 21, 2014 1:57 PM

Answers