none
ew4 permission denied (550) RRS feed

  • Question

  • I get ew4 permission denied 550 errors when I try to publish. I have a brand new Windows 7 computer with ew4 installed. I called my hosting ISP and learned that there was no problem with permissions. I was able to publish from my old Windows XP using the exact same username and password with no problems. My ISP (AmHosting) requested I use the FileZilla FTP program and I did, again with the same username and password and no problems, everything worked perfectly.

    I do not think the problem is in the naming of folders because using FileZilla, and EW4 use the exact named folders and paths. Neither do I think the problem is the setting because the old computer (Windows XT) and the new computer (Windows 7) have the same EW4 program and the Site Setting are identical; checked and rechecked. If the problem is not the ISP, nor EW4 nor the naming of files and folders, nor the Site Settings, what could it be?

    BTW, I have successfully transferred one file with my old computer to the ISP server after I use FileZilla to transfer all the files and folders for the website from my EW4 created site on my computers.

    Also, I have read several posts that popped up when I searched the forum for this problem, but most of them were quite old 10 and (2010 and 2011) and I didn't find a solution to my problem. I doubt it is the server, rather I bet it is some setting in EW4 that causes that type of server error.


    timburleigh

    Tuesday, February 5, 2013 4:39 AM

Answers

  • Generally, 550 is a server error - no permission from the server to do what is asked - are you sure your publishing settings include the correct ftp directory?  (And check that you are not out of space on the server.)
    • Edited by KathyW2 Tuesday, February 5, 2013 6:11 AM
    • Marked as answer by TimBurleigh Tuesday, February 5, 2013 7:14 PM
    Tuesday, February 5, 2013 6:08 AM
  • I THINK I SOLVED THE PROBLEM! Finally, after wondering how to compare the Connections Settings that show the name of the connection, the type of connection, the location and the directory, and the credentials (Username/Password), I clicked on Publishing Settings, Publishing tab, then the Edit button (before I was always clicking the Add and reinputting what I thought was the correct settings). There popped up my Connection Settings that I could compare with the Connection Settings on my old computer EW4. An don'tchaknow, the directory "httpdocs" was missing on the new computer but present on the old computer.

    So, credit to KathyW2, she was on the right track with checking "the correct FTP directory." I just didn't know how to compare the settings on one until by accident I clicked on the Edit button under the Publishing tab of Publishing Settings.

    Thanks for your help Steve and Kathy. Sorry to be so dense as to not make the connection. I thought I had when I reentered the Connection Settings using the add button. I was wrong.


    timburleigh

    • Marked as answer by TimBurleigh Tuesday, February 5, 2013 7:18 PM
    Tuesday, February 5, 2013 7:18 PM

All replies

  • Do you have a firewall, and is EW allowed through it?

    • Edited by KathyW2 Tuesday, February 5, 2013 6:07 AM
    Tuesday, February 5, 2013 4:43 AM
  • Yes, I have a firewall but how do I check to see if EW is allowed through it?

    timburleigh

    Tuesday, February 5, 2013 5:38 AM
  • OK, I checked the firewall settings and allowed EW3 and EW 4 to get through it. However, I still get the same error (550)

    timburleigh

    Tuesday, February 5, 2013 5:56 AM
  • Generally, 550 is a server error - no permission from the server to do what is asked - are you sure your publishing settings include the correct ftp directory?  (And check that you are not out of space on the server.)
    • Edited by KathyW2 Tuesday, February 5, 2013 6:11 AM
    • Marked as answer by TimBurleigh Tuesday, February 5, 2013 7:14 PM
    Tuesday, February 5, 2013 6:08 AM
  • Yes, I checked both of those things. I was made aware of them by reading old posts about the problem. As I said, I was able to use FileZila to publish but EW will not due to the 550 error.

    timburleigh

    Tuesday, February 5, 2013 6:15 AM
  • Is the active / passive publishing setting in EW the same on the 7 machine as it is on the XP machine?
    Tools > Application Options > FTP tab.

    Expression Web MVP

    Tuesday, February 5, 2013 1:56 PM
  • Steve,

    Yes it is the same in both computers. You are speaking of the checkbox in Tools, Application Options, in the FTP tab. However, you have opened a new field of inquiry. I checked all the tabs under Applications and they are all identical between the old computer (that publishes without a problem) and the new computer (that does not publish without error).


    timburleigh

    Tuesday, February 5, 2013 4:19 PM
  • Steve,

    I have been messing around checking, rechecking, reconfiguring server connections, then rechecking again, and something happened. I don't know why but for some reason my new computer sent a new folder to the server and was able to publish into that folder with no problem. So I know it is a settings issue but I cannot for the life of me know what to adjust. By the way, publishing to the new folder, which is the same name as the one on My Documents, My Websites, isn't acceptable because that isn't the one that goes out on the Internet.


    timburleigh

    Tuesday, February 5, 2013 5:08 PM
  • KathyW2,

    Also, if FileZilla and my EW4 on my old computer are able to publish successfully, how can it be a host server problem? Even though the Publishing Settings are (or appear) identical on my new computer, the problem must lie with some setting somewhere on my new computer. Or, is my logic wrong? For the 4th time, my host server tech says everything is OK regarding permissions. He is not able to help with EW4 settings as he only knows FileZilla and similar FTP programs.


    timburleigh

    Tuesday, February 5, 2013 7:03 PM
  • I THINK I SOLVED THE PROBLEM! Finally, after wondering how to compare the Connections Settings that show the name of the connection, the type of connection, the location and the directory, and the credentials (Username/Password), I clicked on Publishing Settings, Publishing tab, then the Edit button (before I was always clicking the Add and reinputting what I thought was the correct settings). There popped up my Connection Settings that I could compare with the Connection Settings on my old computer EW4. An don'tchaknow, the directory "httpdocs" was missing on the new computer but present on the old computer.

    So, credit to KathyW2, she was on the right track with checking "the correct FTP directory." I just didn't know how to compare the settings on one until by accident I clicked on the Edit button under the Publishing tab of Publishing Settings.

    Thanks for your help Steve and Kathy. Sorry to be so dense as to not make the connection. I thought I had when I reentered the Connection Settings using the add button. I was wrong.


    timburleigh

    • Marked as answer by TimBurleigh Tuesday, February 5, 2013 7:18 PM
    Tuesday, February 5, 2013 7:18 PM