none
Windows 7 64bit. I uninstalled .NET Framework 3.5. Trying to re-install but failing. RRS feed

  • General discussion

  • Hello. I believe (cannot completely remember) that I uninstalled .NET Framework 3.5 awhile ago. I then installed .NET Framework 4.0. But, for a game I was trying to play, I needed to have the Microsoft .NET Framework 3.5 checked on in "Turn Windows Features On and Off". Every time I tried it would fail. This led me to believe I had to re-install 3.5. I uninstalled .NET Framework 4.0. When I tried to re-install .NET Framework 3.5 that installation also failed.

    Here is the error that I get with the installation: 

    [07/19/13,11:04:48] Microsoft .NET Framework 3.5 (x64) 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 (x64) 'package'. MSI returned error code 1603
    [07/19/13,11:04:52] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component is marked to be uninstalled but CBSPackageName is not authored - CCBSComponent::SetManager()
    [07/19/13,11:04:52] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component can't be uninstalled as CBSPackageName is not authored - CCBSComponent::SetManager()
    [07/19/13,11:04:53] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 (x64) 'package' is not installed.

    Any help would be appreciated. I really don't know what I am doing. Thank you.

    Friday, July 19, 2013 4:16 PM

All replies

  • As .NET Framework 3.5.1 (.NET 2.0, 3.0 and 3.5 through 3.5 SP1) is an embedded component of the Windows 7 OS, it is not user removable or installable.

    First, lets find out what .NET Frameworks you have.

    Use this .NET Framework verification tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Please run the tool with .NET Framework 3.5 selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    The results will tell us if there are any issues with your embedded .NET Frameworks, and we can then proceed based on the results.

    Saturday, July 20, 2013 2:38 PM