locked
Infopath sharepoint data connection causes login prompt RRS feed

  • Question

  • Hello

      I have an Infopath 2007 form developed with InfoPath 2010 running in a MOSS 2007 Form Library. The form is fully trusted with a valid certificate signed.. I can use the form without issue. My problem is I have several users who are getting prompted for credentials when they go to open the form. The dialog box is not the standard Windows authentication prompt it seem sto be an InfoPath one but i am unsure.. I can tell from the box that it is accessing a web service on the SharePoint site the form is published to. I do not have any web service data connections setup but I do have 3 Sharepoint list data connections setup.. I am assuming this is Infopath talking to SharePoint via it's web services for these connections.. Permissions for this site are simple, myself and my team are owners and the rest of the entire domain is contribute.. Only about 10-15 of my 50 users using this form are having this problem.

      I have attached a screenshot of the issue.

    Tuesday, May 8, 2012 1:29 PM

Answers

  • Hi Joe,

    Could you please kindly check the problem users' permission on target list/site, make sure them have at least read permission on target list.

    Add the site which holds target list as trusted site in IE.

    If the problem persists, please export the web service as a UDC file, and add authetication element in the UDC file, then use the UDC file as the data source instead. See following references for the details.

    1. Integrate InfoPath with the Data Connection Library.
    http://msdn.microsoft.com/en-us/library/bb267335(v=office.12).aspx
    2. Add Authentication element to UDC file.

    <udc:Authentication>
    <udc:UseExplicit CredentialType="">
    <udc:UserId/>
    <udc:Password/>
    </udc:UseExplicit>
    <udc:SSO AppId="" CredentialType=""/>
    </udc:Authentication>
    http://blogs.msdn.com/b/infopath/archive/2006/10/30/the-anatomy-of-a-udc-file.aspx

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact
    tnmff@microsoft.com.


    Emir Liu

    TechNet Community Support

    • Marked as answer by Emir Liu Thursday, May 17, 2012 3:19 AM
    Wednesday, May 9, 2012 10:37 AM

All replies

  • Hi Joe,

    Could you please kindly check the problem users' permission on target list/site, make sure them have at least read permission on target list.

    Add the site which holds target list as trusted site in IE.

    If the problem persists, please export the web service as a UDC file, and add authetication element in the UDC file, then use the UDC file as the data source instead. See following references for the details.

    1. Integrate InfoPath with the Data Connection Library.
    http://msdn.microsoft.com/en-us/library/bb267335(v=office.12).aspx
    2. Add Authentication element to UDC file.

    <udc:Authentication>
    <udc:UseExplicit CredentialType="">
    <udc:UserId/>
    <udc:Password/>
    </udc:UseExplicit>
    <udc:SSO AppId="" CredentialType=""/>
    </udc:Authentication>
    http://blogs.msdn.com/b/infopath/archive/2006/10/30/the-anatomy-of-a-udc-file.aspx

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact
    tnmff@microsoft.com.


    Emir Liu

    TechNet Community Support

    • Marked as answer by Emir Liu Thursday, May 17, 2012 3:19 AM
    Wednesday, May 9, 2012 10:37 AM
  • Try to disable the loop back check on the farm servers.

    1) Click Start, click Run, type regedit, and then click OK.
    2) In Registry Editor, locate and then click the following registry key: 
    3) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    4) Right-click Lsa, point to New, and then click DWORD Value.
    5) Type DisableLoopbackCheck, and then press ENTER.
    6) Right-click DisableLoopbackCheck, and then click Modify.
    7) In the Value data box, type 1, and then click OK.
    8) Quit Registry Editor, and then restart your computer

    Saturday, October 20, 2012 7:34 PM
  • In this scenario we have to hard code any one of the user credentials. Is this possible to pass login user credentials instead of hard code values in the connection string?

    Srinu Tamada

    Friday, December 14, 2012 6:16 AM