An error was encountered in the transport layer RRS feed

  • Question

  • I am fairly new to SSAS 2005.  I have just created one cube.  I was able to create an Excel pivot table that connected to this cube and had all the funtionality that I expected.  I then published the pivot table as a web page.  When I view the web page on the server where SQL 2005 is loaded the web page comes up with all of the expected functionality.  But when I try to view the web page from another computer on my network I gett the error


    The query could not be processed:

                        An error was encounted in the transport layer

                        The peer prematurely closed the connection.


    Any suggestions on how to proceed.


    Monday, January 15, 2007 7:17 PM


All replies

  • Even though this is a web page, the page actually contains an ActiveX pivot table control which executes on the client machine. The client machines will need to have the OLEDB provider for SSAS 2005 installed in order to connect to SSAS 2005. You can download the "Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider " from the feature pack download page (about half way down) at http://www.microsoft.com/downloads/details.aspx?FamilyID=df0ba5aa-b4bd-4705-aa0a-b477ba72a9cb&DisplayLang=en 

    If this still does not help, there is a great article on troubleshooting connectivity issues with SSAS at http://sqljunkies.com/WebLog/edwardm/archive/2006/05/26/21447.aspx

    Tuesday, January 16, 2007 1:19 AM
  • I've loaded SSAS OLE DB 9.0. I've allowed anonymous users and I still get the error.  Any other suggestions.
    Tuesday, January 16, 2007 2:42 PM
  • Trying using the domain name in front of your user name (domain\username)
    Tuesday, January 30, 2007 4:52 PM
  • You could try tracing the SSAS server while you try to connect to see if there are any error events that appear.

    The following thread from the newsgroup might also provide some ideas:



    Wednesday, January 31, 2007 1:32 AM
  • Hi,


    I'm having a similar problem except it's less consistent (*sigh*).  The situation: I have SSAS 2005 running on a non-domain machine (it's a test setup) along with Project Server 2007.  I then have a few client machines I'm trying to connect with.  The hitch is that one of them is able to connect with any method I try (.udl file, Excel PivotTable, or the Data Analysis Web components in the Project Server) - in SQL Server Profiler, I see the correct NTUserName appear (I have a couple of users created on the server).  However, when I try to connect with another machine using Data Analysis components with IE7, I get the error "An error was encountered in the transport layer." and "The peer prematurely closed the connection."; the profiler shows the NTUserName is "Anonymous", yet I'm using the same user credentials.  To make things interesting, on the problem machine, I can successfully connect using the .udl file method and Excel (the NTUserName is correct).  Just for completeness, I have no problems when trying to connect locally from the server.


    I'm reasonably sure the settings for Internet Explorer are correct and that I have the correct components installed (like OLE DB Provider for Analysis Services 9.0) otherwise no method would work.  I'm just not sure why the user credentials are making it okay from one machine and not the other (and from different methods, to boot).  Just for funsies, I enabled Anonymous access to SSAS but that had no difference.  For reference, the machine that works is Vista and the machine that does not is XP SP2.  Both machines are fully patched.


    I have tried the suggestions in both of these following Web pages (and a variety of other postings) to no avail:





    Other things:

    • The firewall on the server is off
    • "Access data sources across domains" is enabled (IE option)
    • "Automatic logon with current user name and password" is enabled in all browsers I try (IE option)


    Does anyone have any suggestions?






    Friday, June 8, 2007 4:57 PM
  • thanks it worked


    Monday, January 14, 2008 11:55 PM

    Hi ,

    How did you get it resolved ? I am still getting the thi errorr....I am getting frustated now. Please let me know .

    Much Thanks.



    Thursday, January 24, 2008 10:06 PM
  • Hi,


    I am trying to connect to an OLAP cube that was deployed on a remote machine using Excel 2003. While connecting the 'Multidimensional Connection 9.0' dialog box is giving me 'An error was encountered in the transport layer' error, when I try to log in using SQL Server autenticated user ID. And if I try to connect using my windows login Id, it connects but does not enlist any databases.


    Please help.

    Tuesday, April 15, 2008 7:10 AM
  • SSAS does not support SQL logins so this will not work. It only supports windows logins and your login would either need to be in the server administrators role (where you would be able to see everything) or your login would need to be added to a role in the database with rights to see specific cube.


    This article has information on resolving connection issues. http://www.microsoft.com/technet/prodtechnol/sql/bestpractice/CISQL2005ASCS.mspx but you get the "transport layer" issue when trying to connect from a non trusted domain.

    Tuesday, April 15, 2008 7:17 AM
  • Thanks Darren.

    Wednesday, April 16, 2008 8:16 AM
  • Hi Chris,

     Am facing the exact same problem as you have stated, the only difference is that the machines that I have been able to access from are identical in terms of hardware / software to the machines that I have not been able to access from.

    While am still trying to sort this out, wanted to share something that could possible help you as well. Its got absolutely nothing to do with the settings on IE  / software on the client machine. Its an access related authenticating issue on the server. Try right clicking internet explorer and do a "run as" , with the domain user name and password of the machine that has been able to login and voila , it worked for me.

    I shall try and update on the final solution once I get my tech team to work out the access rights to my user ID.

    All the best !

    • Proposed as answer by WolfgangVF Thursday, September 17, 2009 4:50 PM
    Friday, September 19, 2008 12:10 PM
  • FYI...I was receiving the exact same error in my SSAS 2008 environment when attempting to sync databases between two SSAS 2008 instances. The root cause was that the SQL Server Analysis Services on the source was running under a domain service account and the SQL Server Analysis Services on the destination was running under the System account. When I changed the destination server to use the same account as the source server the sync script completed successfully.
    Thursday, September 17, 2009 4:54 PM
  • Chris -

    Did you ever find a resolution to this issue?  I am running into this issue right now with the same symptoms you had.


    Monday, October 12, 2009 11:00 PM
  • Many Thx.
    Tuesday, June 8, 2010 11:50 AM
  • thanks chris...it worked for me

    Monday, February 13, 2012 7:43 PM
  • i have the following Problem. if i connect from the Business Objects Reporting tool to the Olap-Cube i get the first time the Error "... an error was encountered in the transport layer'. when i refresh the report a second time then i get data from the cube. in the trace you see that first he try to connect as anonymus and second as my user. i dont why he try to connect as anonymus. in the connectionproperties exist only my user server-ip\username.
    Can someone help me ?
    Monday, May 21, 2012 11:47 AM