none
Can not Configure Biztalk EDI/AS2 Runtime in Biztalk Server 2010 RRS feed

  • Question

  • I have VS 2010, BT 2010, SQL Server 2008 R2 , Windows 7, 32 bit

    While congiguring BT 2010 I am not able to configure EDI/AS2 Runtime

    I am getting Following Error:

     

    <Exception Message="Failed to deploy BAM activity definitions.  Please make sure that all BAM related Data Transformation Services (DTS) packages are removed along with the BAM databases." Source="Microsoft.BizTalk.Configuration.EDIAS2.Utility" HelpID=""><Exception Message="Failed to execute process: C:\Program Files\Microsoft BizTalk Server 2010\Tracking\bm.exe." Source="Microsoft.BizTalk.Configuration.EDIAS2.Utility" HelpID=""><Exception Message="Microsoft (R) Business Activity Monitoring Utility Version 3.9.469.0

    Copyright (C) Microsoft Corporation. All rights reserved.

     

    Using 'BAMPrimaryImport' BAM Primary Import database on server 'Comp'...

     

    Deploying Activity... FileName: 'C:\Users\Admin\AppData\Local\Temp\tmpB53A.xml'

    " Source="Microsoft.BizTalk.Configuration.EDIAS2.Utility" HelpID="" /></Exception></Exception>

    I have done the following remedies:

    1. Unconfiguration

    2.Deleted All BT and BAM databases from SQL Admin

    3.Deleted BAM_............. from MSDB of stored Packages(SQL in Integration Services)

    4.ran the command-------->Bm.exe remove-all -DefinitionFile:<var style="font-family: 'Segoe UI', Arial, Verdana, Tahoma, sans-serif; font-size: 11px; font-weight: bold; line-height: 16px; text-align: left;">folder</var>\AS2ReportingActivityDefs.xml and Bm.exe remove-all -DefinitionFile:<var style="font-family: 'Segoe UI', Arial, Verdana, Tahoma, sans-serif; font-size: 11px; font-weight: bold; line-height: 16px; text-align: left;">folder</var>\EdiReportingActivityDefs.xml

    done..............

    5.BT confugeration Console--->Run as adinistrator----->Basic Configuration----->

    6.  Apply Configuration in Custom Configuration for EDI/As2 runtime after checking the "aggregation" box

    and still it failed 

    I am worried ..... Please help me What can I do ........Need your help.......

    When I did Configuration first time on same laptop It was succeeded........

    Please give me some suggetions...........

    Plz.....Plz.....Plz.....

     

     


    Sunday, December 25, 2011 1:10 AM

Answers

  • Thank you very much for the link,Sriaug.

    But I did not get what exactly he did to install Integration service client tool on Biztalk server 2010. Could you please explain it?

     Jason's Reply

    Jason
     For those that are interested. I managed to solve the strange error. 
    
    No thanks to the description but after some troubleshooting I managed to track it down to the fact that the BTS did not have the Integration services client tools installed on it. (Multi server install)
    
    
    After doing this, the bm.exe tool worked and the AS2 configuration completed. 

     


    • Edited by har Wednesday, December 28, 2011 9:44 PM
    • Marked as answer by Lloyd ZhangModerator Monday, January 2, 2012 3:47 PM
    Wednesday, December 28, 2011 9:43 PM

All replies

  • When you installed SQL did you install integration services?
    Bill Chesnut | BizTalk Server MVP | Mexia Consulting | Melbourne Australia
    http://www.biztalkbill.com
    Please indicate "Mark as Answer" if this post has answered the question.
    Sunday, December 25, 2011 10:16 PM
  • yes from there only I deleted DTS Stored Packeges ( begining  with BAM_.......)

    And Actually When I Configured BizTalk Server 2010 first time It did get configured......

    I am depressed what can be the cause which is not allowing it to configure...................



    • Edited by har Wednesday, December 28, 2011 3:40 PM
    Monday, December 26, 2011 9:34 PM
  • Please do Reply........

    I am struggling to fix that........................

    I am new learner ....................Plz ...Plz.....Plz.....

    Tuesday, December 27, 2011 11:54 AM
  • Hi Bill Awaiting for your reply..................................
    Wednesday, December 28, 2011 3:39 PM
    • Edited by sriaug Wednesday, December 28, 2011 9:07 PM
    Wednesday, December 28, 2011 4:34 PM
  • Thank you very much for the link,Sriaug.

    But I did not get what exactly he did to install Integration service client tool on Biztalk server 2010. Could you please explain it?

     Jason's Reply

    Jason
     For those that are interested. I managed to solve the strange error. 
    
    No thanks to the description but after some troubleshooting I managed to track it down to the fact that the BTS did not have the Integration services client tools installed on it. (Multi server install)
    
    
    After doing this, the bm.exe tool worked and the AS2 configuration completed. 

     


    • Edited by har Wednesday, December 28, 2011 9:44 PM
    • Marked as answer by Lloyd ZhangModerator Monday, January 2, 2012 3:47 PM
    Wednesday, December 28, 2011 9:43 PM
  • Please let me know What can be the reason that I am unable to configure EDI/AS2 Runtime?

     

    Tuesday, January 3, 2012 8:15 AM
  • why dont you un- install everything and start installing everything from start......use the document provided by microsoft...and try to follow each step..  
    • Edited by sriaug Tuesday, January 3, 2012 8:05 PM
    Tuesday, January 3, 2012 6:26 PM
  • Thnks for the reply.I have done that also I have unistalled biztalk and removed its associated things.But still no luck.

    But now I am getting another error as follows:

    Do you have any suggestions for that .

    TITLE: Microsoft BizTalk Server Configuration Wizard

    Failed to configure BizTalk EDI functionalities. (Microsoft.BizTalk.Configuration.EDIAS2.EdiHelper)

    For help, click: http://go.microsoft.com/fwlink/events.asp?ProdName=Microsoft+BizTalk+Server+2010&ProdVer=3.9.469.0&EvtSrc=Microsoft.BizTalk.Configuration.EDIAS2.EdiHelper&EvtID=StrFailedToConfigEDI

     ADDITIONAL INFORMATION:

     Failed to add a resource to a BizTalk application using BtsTask.exe. (Microsoft.BizTalk.Configuration.EDIAS2.Utility)

     For help, click: http://go.microsoft.com/fwlink/events.asp?ProdName=Microsoft+BizTalk+Server+2010&ProdVer=3.9.469.0&EvtSrc=Microsoft.BizTalk.Configuration.EDIAS2.Utility&EvtID=StrFailedBtsTaskAddResource

     ------------------------------

     Failed to execute process: C:\Program Files\Microsoft BizTalk Server 2010\btstask.exe. (Microsoft.BizTalk.Configuration.EDIAS2.Utility)

     For help, click: http://go.microsoft.com/fwlink/events.asp?ProdName=Microsoft+BizTalk+Server+2010&ProdVer=3.9.469.0&EvtSrc=Microsoft.BizTalk.Configuration.EDIAS2.Utility&EvtID=StrFailedToExecuteProcess

     ------------------------------

     Microsoft (R) BizTalk Application Deployment Utility Version 3.9.469.0

    Copyright (c) 2010 Microsoft Corporation. All rights reserved.

     Information: Adding resource (-Type='System.BizTalk:BizTalkAssembly' -Luid='Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35') to application 'BizTalk EDI Application'...

    Serialized BizTalk assembly 'Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' from 'C:\Program Files\Microsoft BizTalk Server 2010\Microsoft.BizTalk.Edi.EdiPipelines.dll'.

    Information: Validating resources (count=1)...

    * Validating resource (-Type='System.BizTalk:BizTalkAssembly' -Luid='Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35')...

    Information: Performing change requests...

    Information: Calling BeginTypeChangeRequest for all selected resource types...

    PerformingBeginChangeRequest

    Updating resource (-Type='System.BizTalk:BizTalkAssembly' -Luid='Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35') in store.

    Information: PerformingEndChangeRequestsWithRollBack

    * Performing EndTypeChangeRequest for resource type 'System.BizTalk:BizTalkAssembly'.

    Error: Failed to add resource(s).

    Resource (-Type='System.BizTalk:BizTalkAssembly' -Luid='Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35')  is already in store and is either associated with another application or with another type.

    Command failed with 1 errors, 0 warnings. (Microsoft.BizTalk.Configuration.EDIAS2.Utility)For help, click: http://go.microsoft.com/fwlink/events.asp?ProdName=Microsoft+BizTalk+Server+2010&ProdVer=3.9.469.0&EvtSrc=Microsoft.BizTalk.Configuration.EDIAS2.Utility&EvtID=StrFailedToExecuteProces

    s

    Friday, January 6, 2012 4:48 PM