none
Why cant I install .Net 3 on my Windows Vista Home Pre. Machine RRS feed

  • Question

  • This is absolutely insane!!! Why can't I install a simple Microsoft product on a Microsoft Operating System? I never had this problem with PHP. I install .Net 3 on my Windows Vista and get an error, the error doesnt say exactly what is the error. Then it sends me to this message board where there are literally dozens and dozens of people with the same issue. Telling me to look for .dll files in my Systems folder. For me since this is my first .Net set up, I don't have that previous file from .Net 2.0 set up. So what is the issue now? Why can't I simply install .Net on to this Windows Vista Machine? This is so frustrating for me, I feel like leaving Microsoft, buying a Mac and staring in one of those commercials. And say.. Microsoft software can't even install on a Microsoft Machine. I appologize for my rant (if thats how you see it). But I've lost critical hours today that cost me money. I am very upset that I can't speak to anyone from Microsoft, and that it takes a Princeton University Math Nerd to answer this simple question. Why do I keep getting errors?

    I've read ever post from this http://social.msdn.microsoft.com/Forums/en/vsexpress2008installationandsetup/thread/cf407d53-acb3-4976-ae8b-fab50099c320

    and still no solution.

    UGG!!! This sucks!!!!
    • Moved by nobugzModerator Sunday, August 16, 2009 12:51 PM (From:.NET Base Class Library)
    Sunday, August 16, 2009 10:49 AM

Answers

  • You didn't mention the error, hard to help you.  .NET 3.0 is already pre-installed on Vista, don't mess with it.  Moved to .NET Setup.

    Hans Passant.
    • Marked as answer by YiChun Chen Friday, August 21, 2009 4:16 AM
    Sunday, August 16, 2009 12:51 PM
    Moderator
  • Hi HelpMeInstall,

    As nobugz mentioned, .NET Framework 2.0 and 3.0 are included as the component of Vista. Thus, you cannot and do not need to manually install them.
    To check .NET Framework, you can try using Verification Tool to verify .Net Framework 2.0, 3.0.

    Hope this helps!

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, August 21, 2009 4:16 AM
    Monday, August 17, 2009 10:17 AM

All replies

  • You didn't mention the error, hard to help you.  .NET 3.0 is already pre-installed on Vista, don't mess with it.  Moved to .NET Setup.

    Hans Passant.
    • Marked as answer by YiChun Chen Friday, August 21, 2009 4:16 AM
    Sunday, August 16, 2009 12:51 PM
    Moderator
  • Hi HelpMeInstall,

    As nobugz mentioned, .NET Framework 2.0 and 3.0 are included as the component of Vista. Thus, you cannot and do not need to manually install them.
    To check .NET Framework, you can try using Verification Tool to verify .Net Framework 2.0, 3.0.

    Hope this helps!

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, August 21, 2009 4:16 AM
    Monday, August 17, 2009 10:17 AM