locked
HTTP Error 401.3 RRS feed

  • Question

  • User-1280494111 posted

      I am in need of a little assistance. IM trying to install php on a test 2k3 server. I started by making sure i caoould get the localhost page to come up then added the php, but everytime i try and load the test page i get this error. I have given full access to iusr_computername andiis_wpg for the inetpub folder and my php folder. I went into the iis manager and check the permissions there and made sure both were listed. I allowed anonymous access with the iusr_machinename accout and still no go.

    any help will be greatly appreciated.

    Wednesday, June 18, 2008 1:33 PM

Answers

All replies

  • User-1341446551 posted

    Do you have the proper previleges set for the php folder??

    Also check if you have installed PHP correctly on the box ..

    Check this for PHP with FastCGI on IIS 6:

    http://www.iis.net/downloads/default.aspx?tabid=34&g=6&i=1521

    http://www.iis.net/php

     401.3 means that the access is being stopped by the ACL...

    Hope this helps...

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, June 18, 2008 3:33 PM
  • User-1280494111 posted

     Thanks for the reply. I rechecked the permissions for the php folder and iusr_machinename and iis_wpg both have full access to the folders. I followed the instructions from http://www.peterguy.com/php/install_IIS6.html

    and

    http://www.videotutorialzone.com/web-technologies/php/installing-php5-on-windows-2003-and-iis6.html

     I mainly used the video tutorial because it faster and didnt involve much set up. I did add the reg file from the 1st so i could keep the php.ini in the php folder.

    I downlaoded the iis auth Diagnostics 1.0 tool but it just told me the same thing i already knew. 

    Wednesday, June 18, 2008 5:49 PM
  • User-1341446551 posted

    Which version of windows are you using?

    Friday, June 20, 2008 12:54 PM
  • User-1280494111 posted

    im using Server 2k3 sp2

     

    Today i removed all the php changes i made to the server. I proceeded to re-installphp according to  this guide http://www.peterguy.com/php/install_IIS6.html and im still getting the "HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource." I checked the permissions again they seem right on the inetpub folder and my php folder.

     
     

    Saturday, June 21, 2008 3:43 AM
  • User-1341446551 posted

    Under which identity is your AppPool running... ?? check if that identity is having correct privileges ... Also check if the non-php websites are running properly...   

    Saturday, June 21, 2008 11:17 AM
  • User-1280494111 posted

     

    Under which identity is your AppPool running... ?? check if that identity is having correct privileges ... Also check if the non-php websites are running properly...   

     

    My app pool was running under network service but i changed it to the iusr_computer name. now when i try and connect to the website i get service unavailiable. ARGH! lol. So i changed it back to network service and not were getting the happy 403 error once again

    Thursday, July 3, 2008 12:54 PM
  • User-1341446551 posted

    What about the non-php sites are they working???

    Thursday, July 3, 2008 2:51 PM
  • User-1280494111 posted

     Well i dont have any other sites running, but if i remove the index.php page my index.htm page does display

    Thursday, July 3, 2008 3:44 PM
  • User-1341446551 posted

    try removing show friendly HTTP error messages in IE and check the page again ... Also  did you move any files to system32 ??  

    Tuesday, July 8, 2008 2:27 PM
  • User-1280494111 posted

    First off thanks for helping me get this thing going.

     I turned off the show friendly http error deal and im still getting the same issue. And i did copy php5ts.dll into my system 32 folder.

     

    Also if you have a different php install guide that worked for you let me know as well.

     

    thanks

     this is what i get from using the ms authentication and access control diagnostics 1.0 tool

    AnonymousUserPass
    logon failedPath:W3SVC
    AuthType:Anonymous


    AnonymousPasswordSync
    The current configuration requires IIS subauthentication. However, the IIS subauthentication component, iissuba.dll, is not currently configured.

    Path:W3SVC
    AuthType:Anonymous


    AnonymousPasswordSync
    The current configuration uses IIS subauthentication for anonymous authentication. This requires that the worker process be configured to run as the Local System identity, which is not recommended for security reasons.Path:W3SVC
    AuthType:Anonymous


    Server's response: HTTP/1.1 401 Unauthorized
    Learn about IIS status codes

    Path:W3SVC/1/ROOT
    AuthType:Anonymous

     

    here are the permissions from my php folder

    C:\php
     Everyone: (OI)(CI)R
     SHABAZZ\IIS_WPG: (OI)(CI)F
     SHABAZZ\IUSR_SHABAZZ: (OI)(CI)F
     HOME\IUSR_HOMESERVER: (OI)(CI)F
     BUILTIN\Administrators: (OI)(CI)F
     CREATOR OWNER: (OI)(CI)(IO)F
     NT AUTHORITY\SYSTEM: (OI)(CI)F
     BUILTIN\Users: (CI)(special access:)
                             SYNCHRONIZE
                             FILE_WRITE_DATA
                             FILE_ADD_FILE
     
     BUILTIN\Users: (CI)(special access:)
                             SYNCHRONIZE
                             FILE_APPEND_DATA
                             FILE_ADD_SUBDIRECTORY

     

    And from my wwwroot folder

    c:\inetpub\wwwroot\.
     SHABAZZ\IUSR_SHABAZZ: (OI)(CI)(DENY)(special access:)
                                                      DELETE
                                                      FILE_DELETE_CHILD
     
     BUILTIN\Administrators: (OI)(CI)F 
     SHABAZZ\IIS_WPG: (OI)(CI)F 
     SHABAZZ\IUSR_SHABAZZ: (OI)(CI)F 
     HOME\IUSR_HOMESERVER: (OI)(CI)F 
     NT AUTHORITY\SYSTEM: (OI)(CI)F 
     BUILTIN\Users: (OI)(CI)R 

    c:\inetpub\wwwroot\index.php


     SHABAZZ\IUSR_SHABAZZ: (DENY)(special access:)
                                                      DELETE
                                                      FILE_DELETE_CHILD
     

    Tuesday, July 8, 2008 3:22 PM
  • User-1280494111 posted

     Well i didnt get the issue resolved to my likeing but its working. I reloaded server 2003. Reloaded iis and installed php 5.2.6 no go. i re added all permission and etc, still nogo. So luckly i still had php 5.2.5 so i re intalled it and boom i got a php info page. I didnt change any permissions or anything. well its up for now, dont really understand why the newer version didnt work. I even redown loaded it.

    Friday, July 11, 2008 7:04 PM
  • User-1341446551 posted

    I think this could have solved your problem ...

    http://support.microsoft.com/kb/332167

    Monday, July 14, 2008 1:45 PM
  • User-1547666210 posted

    Hello,

      I have the same problem on Windows Xp Proffessional with IIS 5.1

    I'm trying to install the latest version which is PHP 5.2.6. I downloaded the zip version from the website I've copyed all the content to C:\PHP5 , edited the php.ini file.

    I added the php5isapi.dll as ISAPI  filter also added the .php extension to php5isapi.dll from Web Sites -> Home Directory -> Configuration -> Mapping . Also execute permissions are set to Scripts Only.

    I assigned Full access for users IWAM_MACHINENAME and IUSR_MACHINENAME on folder C:\PHP5 and also on C:\Intepub\wwwroot.

    I added C:\PHP5 Path to system and user variables.

    My html, asp and aspx pages work good except the php files that trigger the 401.3 error.

    I understand that this is a permission error, but I assigned all the rights for those users. I don't know what to do next....

     Thanks

    Saturday, August 9, 2008 12:57 PM
  • User-1280494111 posted

    Did you move php5ts.dll to your system32 folder? if so make sure you add the appropiate permissions to the file.

    Sunday, August 10, 2008 6:50 PM