none
Page header plus page footer is too large for the page RRS feed

  • Question

  • Hi, I don't know much about crystal reports but I'm getting the following error on some computers when trying to view the report:

     

    "Page header plus page footer is too large for the page"

     

    I've looked at the report and the entire report is contained in the header and footer so I could see it possibly being large. The question is, why is it only too large on these certain computers. I've read that if there is no default printer or the printer's default settings make the page too small (via margins?) that this can happen. Can someone explain the dependence of the crystal report viewer on the default printer? How do you make reports robust regardless of the user's printer? Thanks.

    Tuesday, May 20, 2008 5:30 PM

All replies

  • I think, this is a Crystal Reports bug.
    Try to change the default printer's format to portrait.

    see also the support forum http://support.businessobjects.com/forums/message.asp?fid=341&sk=5&ps=25&pn=33&mid=106893
    • Proposed as answer by mohammad2 Monday, July 30, 2012 10:00 AM
    Wednesday, May 21, 2008 1:24 PM
  • I saw that link before posting but didn't really find anything too helpful other than the fact that viewing the report is closely tied to your default printer. The report is actually laid out in a landscape format so would the default printer's format need to be set to landscape? If so, we're saying that the user has to set their printer to print landscape layout pages from all applications just to be able to be able to view a report in the .NET report viewer?

    Wednesday, May 21, 2008 3:25 PM
  • I had exactly the same problem with the report. I've changed the layout to portrait, and the bug dissapeared, as well as the possibility to change it back to landscape. Take care.

    Wednesday, May 21, 2008 3:29 PM
  • Ok well that sounds like one solution. Thanks. It seems like it curing a symptom and not the cause though also. I need to know why it thinks it's too large in this one instance to be satisfied. That way I can avoid the bug in the future.

     

    Wednesday, May 21, 2008 3:33 PM
  • Hi , the report designer of my team , show me that error , then we find in the website of businessobject but we dont find the solution , an Sergiu Dudnic give us a good idea, we change the default printer to the One Note 2007 in Control Panel/Printers , and then we change in printing preferences  the type of papper , and then work find.
    Knowledge and Practice
    Thursday, July 31, 2008 1:24 AM
  •  Interesting, that's for the tip.
    Friday, August 15, 2008 9:53 PM
  • Hi, I don't know much about crystal reports but I'm getting the following error on some computers when trying to view the report:

     

    "Page header plus page footer is too large for the page"

     

    I've looked at the report and the entire report is contained in the header and footer so I could see it possibly being large. The question is, why is it only too large on these certain computers. I've read that if there is no default printer or the printer's default settings make the page too small (via margins?) that this can happen. Can someone explain the dependence of the crystal report viewer on the default printer? How do you make reports robust regardless of the user's printer? Thanks.

     

    Hi, here is what i did and its works fine.

    go to Printer Setup -> and check landscape or check No printer

    Thursday, February 10, 2011 11:58 PM
  •    If you use crystal report you can set the the report's orientation at run-time.

        Following is a sample for VB:

        Dim crxApp As New CRAXDRT.Application

        Dim crxReport As New CRAXDRT.Report

        'open report

        Set crxReport = crxApp.OpenReport("your Crx report.rpt")

        'set report PaperOrientation

        crxReport.PaperOrientation = crPortrait

    Wednesday, February 1, 2012 4:49 AM
  • For me, it was caused by the windows default printer settings being set to a default printer that was disconnected from the network.

    I changed the windows default printer settings to another network printer, and crystal displayed the report correctly.

    So yeah, before trying anything severe, try changing the default printer settings in windows to another printer on your network

    Regards

    martin

    • Proposed as answer by PaulKNj Friday, September 11, 2020 5:09 PM
    Tuesday, February 21, 2012 9:59 AM
  • Simply go to printer area make a one by default printer and just set paper A4 Size and 300 dpi resolution finish the story

    thank you

    it's Ketan R. from India

    ketan.uae@gmail.com

    Tuesday, March 27, 2012 3:20 PM
  • I think, this is a Crystal Reports bug.
    Try to change the default printer's format to portrait.

    see also the support forum http://support.businessobjects.com/forums/message.asp?fid=341&sk=5&ps=25&pn=33&mid=106893

     Thank you,

     i just change the default printer...

    • Edited by mohammad2 Monday, July 30, 2012 10:01 AM
    Monday, July 30, 2012 10:01 AM
  • Hi,

    Please follow the steps to solve this type error while executing crystal report.

    step 1:open .rpt file

    step 2:Go to Crystal Reports menu on top

    step 3:select Design then page setup and select print option Microsoft XPS document writer in dropdown list.

    step 4:In margin,make all by default 0.00 

    Friday, February 6, 2015 7:58 AM
  • THANKS A MILLION..

    I was almost getting frustrated...thanks man...

    I was imagining going back to the source code and doing stuff...Your hint worked like charm...

    I just changed the default printer settings "before trying anything severe"

    Friday, September 11, 2020 5:09 PM