none
[Node.js][Mobile Apps] "Enabling Mobile Extension for your App" in Easy Tables RRS feed

  • Question

  • I recently updated my node mobile service to a mobile app, it appears to work fine in the app, however, I can no longer access the easy tables in the portal, which is important for me to moderate content. It is stuck on "Enabling Mobile Extension for your app". I cloned a backup into a new mobile app, where it was only enabling for a few minutes before the tables showed up, however even on there the content doesn't load. Any help? Would like to use just the original mobile app. I looked at the one other question that was similar to this and the answer concluded that there was a bug that crashes the extension "based on what files are deployed", and that the bug was fixed. It appears not though. The person asking waited a couple weeks it seems before the bug "disappeared". Any ideas to solve this?

    Monday, January 18, 2016 4:05 AM

All replies

  • Hello,

     

    We are working on the query and would get back to you soon on this. I apologize for the inconvenience and appreciate your time and patience in this matter.

     

    Best Regards,

    Kamalakar K

    Monday, January 18, 2016 6:00 PM
  • Could you please share your service name so we can take a closer look at it?

    If you don't want to publicly share your service name, please follow the instructions here: https://github.com/projectkudu/kudu/wiki/Reporting-your-site-name-without-posting-it-publicly

    Thank you!

    Tuesday, January 19, 2016 5:53 PM
  • Yes, pretino.azurewebsites.net 
    Saturday, January 23, 2016 6:43 AM
  • Hi Samtm,

    your query is little confusing or unclear. Could you help me with step by step procedure on what you are trying to do with a screenshot of error message.


    Monday, February 1, 2016 9:43 PM
  • Can you go to your site settings and look under Application Settings and check if you have an application setting named "MS_MobileManagementMode"? This is automatically added to migrated sites. If you find that setting, can please remove it (or rename it to something else), restart your site and try again to see if that helps?

    Thanks,

    -Fabio

     
    Monday, February 1, 2016 9:56 PM
  • Hi Samtm,

    your query is little confusing or unclear. Could you help me with step by step procedure on what you are trying to do with a screenshot of error message.


    https://gyazo.com/81f52c484d566c54ce574dac8c4a53d4

    There's a screenshot, notice in the top right the "Enabling Mobile extension for your app", That appears whenever I click on Easy Tables, ever since I migrated the app from a mobile service to a mobile app. I can't see the tables or what's inside, however I can assume it's functioning correctly as my mobile app has been working fine since it started a couple weeks ago. Nonetheless I still need to be able to view the contents and regardless how long I leave the window open, the message goes on forever. I tried Fabio's suggestion and unfortunately the issue remains. As I mentioned in the original post, I backed up the mobile app, and made a new mobile app. Restored the backup there, and the message only lasted for a few minutes before the tables showed up. I could not however click on the tables.

    Tuesday, February 2, 2016 11:11 AM
  • Thanks for the advice, unfortunately this did not solved the issue.
    Tuesday, February 2, 2016 11:12 AM
  • Hi Sam,

    You said you Migrated your mobile service but the website name you provided contradicts this.

    azure-mobile.net would be the uri path of a Migrated Mobile service. See: https://azure.microsoft.com/en-us/documentation/articles/app-service-mobile-migrating-from-mobile-services/

    Can you provide more details on exactly what you did?

    -Jeff


    Jeff Sanders (MSFT)

    @jsandersrocks - Windows Store Developer Solutions @WSDevSol
    Getting Started With Windows Azure Mobile Services development? Click here
    Getting Started With Windows Phone or Store app development? Click here
    My Team Blog: Windows Store & Phone Developer Solutions
    My Blog: Http Client Protocol Issues (and other fun stuff I support)

    Tuesday, February 2, 2016 4:20 PM
  • Jeff brings up a good point.

    I'm looking at your sites and see that although you had a Mobile Service named "pretino" (which was indeed migrated), that site has since been deleted and it looks like you have created a Mobile App with the same name (hence the domain pretino.azurewebsites.net). So the migrated app setting does not apply, since we're dealing with a mobile app.

    How did you initialize the code in your Mobile App? Did you start from the quickstart and created tables using Easy Tables? Or did you deploy custom code to the service? As you pointed out in a previous post, Easy Tables requires a specific folder/file structure in order to enable management. I'm taking a closer look to at some logs to see if I can get more information about what is going on.

    Thanks,

    -Fabio

    Tuesday, February 2, 2016 6:07 PM
  • Samtm,

    After closer analysis, I do see an issue with your site that is likely related to the migration process (and explains the Easy Tables issue you're having).

    I'm working on this issue and will post an update as soon as I have more information.

    Thanks,

    -Fabio

    Tuesday, February 2, 2016 7:04 PM
  • Ahhh, alright. What I should have said was that the mobile service was migrated (January 11th). Where it was working fine.  I was able to view the tables and everything. Then on January 16th, while attempting to publish a web app, the pretino.mobile-service.net domain was accidentally overwritten instead. I managed to restore it, however, I believe restoring it upgraded the mobile app completely, changing the url from pretino.azure-mobile.net to pretino.azurewebsites.net. At the time I didn't realize the app had been upgraded but it would make sense as it it did require me to change the client side code. To answer your question, the tables were created in the original azure portal while it was still a mobile-service (several months ago, unmigrated). If you have anymore questions let me know.
    Tuesday, February 2, 2016 7:47 PM
  • Samtm,

    We have re-added the pretino.azure-mobile.net hostname to the site. Can you test and let is know if that addresses the issue?

    Thank you,

    -Fabio

    Friday, February 5, 2016 1:49 AM
  • Unfortunately, the mobile extension continues to run continuously. Tried restarting it running it for a couple hours and the issue remains.
    Monday, February 8, 2016 3:48 PM