none
Handle & characters in ADF v1 URL RRS feed

  • Question

  • Hi everyone,

    I am having problems connecting to a NAV OData URL. I am using the service URL which works, and i am trying to pass in the company name in the URL in the "USE QUERY" pane with the following code:

    Customers?company="My Company". This setup works fine, even when i use %20 for space character.

    However, i have a company that has an "&" sign, eg. My & Company. ADF seems to completely ignore the & sign and everything after it. I´ve tried the following:

    Customers?company="My & Company

    Customers?company="My%20%26%20Company"

    Strangely enough, when i try Customers?company="My%20%27%20Company", it gives me back saying "My ' Company" doesn't exists, which doesn't.. but anything i try to do to get the & sign, it ignores everything before it and just returns "My" doesn't exist as a company.. 

    Any ideas how to get around this? ADF seems to ignore everything i try..

    Thanks in advance for the help!

    Monday, November 25, 2019 3:33 PM

All replies

  • Hello robbanangi and thank you for your query.  I have a question for you.

    Can you confirm whether this happens without using ADF? (use browser or Curl or Postman or some other tool)

    Since I do not have a Dynamics NAV environment, I cannot test whether it is an issue with the Copy Wizard, or the underlying ADF v1.  If it is an issue with the Copy Wizard, and not the ADF, then it should be possible to work around by using Visual Studio 2015 to author the pipeline.  If this is an issue with ADF v1, then it may be worth considering moving to ADF v2.

    Tuesday, November 26, 2019 2:40 AM
    Moderator
  • Hello!

    I´ve tried to get to this data through Power BI M Code ( Data.OFeed function ) - works like a charm!

    I've also connected to the data through SSIS. There are some bugs there aswell but it works. 

    The customer has this project running on an ADF v1 instance, so initially, i would like to solve it here, but who knows, maybe they will convert their solution to V2 :)

    I´ll see if I can do a workaround by specifying everything in Powershell or something similar! It's just really frustrating that ADF lets me put anything there as a Company string except for an ampersand. Even | and @works, but not & 

    Tuesday, November 26, 2019 7:26 AM
  • Thank you for verifying that it works outside of ADF.  That just leaves the question of whether it is caused by the Copy Wizard layer, or by ADF.  I will ask around internally, see if there are any known work-arounds.

    Tuesday, November 26, 2019 8:43 PM
    Moderator
  • I didn't find any trouble shooting guides for this specific issue.

    You said you tried: 

    Customers?company="My%20%26%20Company"

    Did you try:

    $$Text.Format('Customers?company="My%20%26%20Company"')
    I will escalate the issue if the $$Text.Format does not help.

    Best practice would be to move to ADF v2, as support for v1 is waning.

    Wednesday, November 27, 2019 12:43 AM
    Moderator
  • @robbanangi, did this help?
    Monday, December 2, 2019 10:07 PM
    Moderator