none
Kinect V2 does not work with 3D Builder app RRS feed

  • Question

  • I have installed the SDK's for Kinect V2. I know it works because I can use it in other prog's but the results are not what I want so I am trying to get it to work in Microsoft's 3D Builder app. When opening the app I get the main page waiting for me to hit the scan button. Doing so takes me to the page where I can set size and detail, reset, and on the right is an icon for Frames Per Second. This is red and the numeral is zero. Hitting start does NOTHING but grey out the Start button. The display stays the same dark state.

    The Kinect verification tool gives me a green check mark on everything EXCEPT on USB Controller where there is a yellow exclamation mark. The result text says "Unknown USB 3.0 port detected. Your USB configuration may support Kinect for Windows"

    If I go into my Device Manager to check the name of the USB 3.0 port all it says is "Generic SuperSpeed USB Hub" so I have no idea how to check if that is the problem. Since it DOES work in the other prog's this should NOT be the problem in 3D Builder.

    Any ideas?

    Thursday, January 1, 2015 12:58 AM

All replies

  • check your privacy settings for both the application and the system. All Windows Store applications require that the privacy setting for the system allows Mic and Webcam in addition to the application.

    Carmine Sirignano - MSFT

    Saturday, January 3, 2015 12:55 AM
  • Hi Carmine 

    I have the same problem with the frames for second, I already check the privacy settings for the app and system and in both are activated the webcam and mic.

    What can I do if the problem continue?

    Thanks

    Friday, December 30, 2016 4:19 PM
  • The main problems is you need to be running Windows 10 Anniversary (build 14393) at least.

    Run the Camera app and you should be able to see the "Kinect Sensor 2.0" sees.

    To enable the drivers you must load the latest version of the Kinect 2.0 SDK updated 1st November 2016.

    Remove the Kinect USB plug before installing the updated SDK.

    Restart the Windows 10 PC

    Insert the USB 3.0 Kinect plug, and say no action the repeated question when installing the new drivers.

     Run the Windows 10 Audio troubleshooting menu and select fix NUI Audio sensor connect.

    To run Microsoft's 3D Builder app properly requires at least Window 10 Insider build 14800 and currently the Creators update requires build 14961

    The main point is if the Camera app does not work with Kinect 2.0 sensor you will need to uninstall the old SDK restart PC and install the Updated Kinect 2 SDK on PC.

     Here is my answer to a similar question

    There is a problems there are TWO DIFFERENT size files on download and 89MB, which would appear to be too SMALL and the correct size 275MB

    Kinect 2.0.1410.19000

    It does not help that the filename is called

    KinectSDK-v2.0_1409-Setup.exe but in fact a later version

    to install

    To install the Kinect for Windows SDK 2.0:
    1. Make sure the Kinect sensor is not plugged into any of the USB ports on the computer.
    2. From the download location, double-click on KinectSDK-v2.0_1409-Setup.exe
    3. Once the Kinect for Windows SDK has completed installing successfully. Restart your PC to remove the old drivers
    4. Ensure the Kinect sensor is connected to the power hub and the power hub is plugged into an outlet. Plug the USB cable from the power hub into a USB 3.0 port on your computer. Driver installation will begin automatically.
    5. Wait for driver installation to complete. You can verify that installation has completed by launching Device Manager and verifying that "KinectSensor Device" exists in the device list. Note:On first plugin, the firmware on the device will be updated. This may result in the device enumeration happening several times in the first minute. Always answer "NO Action"
    6. Installation is now complete.
    7. In the Search box, or Start bar Find and start the Camera app, Click the camera rotator until "KinectSensor 2.0". If you are facing the Kinect Camera Face Detection box will be seen.
    8. To enable "Windows Hello with Kinect Sensor 2.0", Settings -> Accounts-> Sign In -> Windows Hello -> Improve Recognition, Twice. Lock the screen and watch Kinect check your Face Recognition
    9. Run Audio troubleshooter and Enable the microphone in Kinect
    10.  Click Cortana Microphone say "To be or not to be"
    11. Enable Cortana to voice train your voice and Click enable "Hey Cortana


    • Edited by jims.halo10 Sunday, January 1, 2017 5:05 PM
    Sunday, January 1, 2017 4:56 PM