locked
Windows 8.1 IAP Purchases Failing RRS feed

  • Question

  • Hi,

    I have had reports of IAP purchases failing on Windows 8.1, and looking at the IAPs page I can see purchases for WP8.1, and Windows 10, but not Windows 8.1

    I tried buying it on another account I have, and the IAP details and price are shown fine, but the purchase fails after typing in the password to confirm the payment.  It says processing payment and then fails.

    Looking at my application logging the API RequestPurchaseAsync is returning NotPurchased.

    The application id is 2af59913-e82a-4474-93a0-f93055278cf3

    Thanks and Regards,

    Matthew.


    Wednesday, September 23, 2015 8:22 PM

All replies

  • I have tried setting up a new account for myself and adding a card, and I'm having the same issue- I can't purchase it on Windows 8.1.  I've tried raising a support request, but had no luck.  Windows 10 and Windows Phone 8.1 seem to be ok...

    Friday, October 16, 2015 10:46 AM
  • Hi Matt,

    I can take a look at your issue, but can you do one thing to help me narrow it down?

    What you can do is leave your IAP (ProfessionalPack) as is, but publish a new submission on your app (Camera Remote). You don't really have to change any data in your app submission, but you do need to "Update" your current submission then "Submit", so that the system will treat the whole thing as a brand new submission. Once this new submission gets published, we can try the IAP purchase scenario again.

    There was a known issue in Windows 8.0/8.1, where IAP submission alone would not be picked up by the app. To compensate that, the parent app has to be published after the IAP is successfully published. Let's see if this is the root cause of your problem.

    Thank you!

    -haonan

    Monday, November 30, 2015 7:43 PM
  • Hi Haonan,

    Thanks for the suggestion.  I did try that (and noticed I needed to do this to pick up a new IAP price), but it didn't fix the issue.  However, I've been talking to support and there was a fix released for a suspected issue (perhaps the same one), and I haven't retried publishing the app since (republishing the IAP after the fix didn't help).

    I will try republishing the app now and let you know how I get on.

    Many Thanks,

    Matt. 


    Monday, November 30, 2015 10:22 PM
  • I tried again after re-publishing the app, and no luck I'm afraid.  The purchase still fails with the same error.

    Saturday, December 5, 2015 1:35 PM
  • Hi Matt,

    By the end of last week we made some progress and narrowed it down to some tax profile propagation issue across systems. The team responsible for this area was trying to patch it from the backend but it may take some additional time. In a few days, in case you still don't see improvement and want to contact customer support for further escalation, please mention bug 5099821 - this is the internal bug id filed directly against the engineering team that is working on this fix.

    Thank you for your patience,

    -haonan

    Monday, December 7, 2015 10:58 PM
  • The patch should be complete by now and please try your IAP purchase scenario again.
    Wednesday, December 16, 2015 11:06 PM