Access 2016 error 80040e37 when accessing linked tables programmatically (VBA) RRS feed

  • Question

  • I have been developing an Access application utilizing two desktops (Win 7 Enterprise 64bit with Access 2013 64bit and Win 7 Home 64bit with Access 2016 Pro 64bit) and a laptop (Win 10 Home 64bit with Access 2016 Pro 64bit). I had prior to my encountering the problem I'm about to describe Office 2007 Enterprise 32bit on both "Home" computers. The databases that I'm developing incorporate multiple databases with multiple tables, with each database accessing the tables of the other "external" databases as "Linked" tables. Everything has been going fine (manually as well as programmatically opening the tables, whether linked or direct - i.e., not externalized).

    And then I installed Office Pro 2016 64bit on both "Home" computers. Now I cannot, for the life of me, programmatically open ANY newly created linked table, getting the infamous 80040e37 error. I can access ALL the tables (old or new, linked or not) manually - i.e., double clicking on the table from within the database. And I can programmatically access ALL the tables (by all computers) which had been linked prior to the install of Office Pro 2016, but not so with ANY table linked after the install (from any of the computers). What's even more baffling is that I'm getting the 80040e37 for new tables linked and accessed by the vintage Access 2013, without Access 2016 being involved at all. I've even created two new databases with Access 2013, manually set up a link, and without Access 2016 being involved at all, still get the same error with Access 2013.

    I've tried not only linking the tables manually, but programmatically as well, with the same results.  I have reinstalled Office Pro 2016 to no avail. I've searched the Internet for clues and/or others experiencing the same problem, but to no avail. (And I cannot believe nobody else has stumbled on this same issue.)
    Wednesday, November 22, 2017 6:09 PM

All replies

  • Hello,

    What is the error message? Do you get "The Microsoft Jet database engine cannot find the input table or query '<name>'. Make sure it exists and that its name is spelled correctly."?

    What code do you use to programmatically access the linked tables?

    According to your description, do you install two Office versions on Win7Home and Win10Home?  

    It is not recommended use several Office versions on one machine. I suggest you uninstall Office 2007, repair Office 2016 and test again. 

    >>I've tried not only linking the tables manually, but programmatically as well, with the same results. 

    In Access2013/Win7Enterprise, the same result means you get the error when opening linked tables manually and programmatically or you get the error only when opening programmatically?

    What is your current Office build number and OS build number? Please update your Office and Windows to latest version and share your build number here. 



    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, November 23, 2017 2:47 AM