locked
My app failed in windows store testing. please give me solution. RRS feed

  • General discussion

  • Content compliance: failed

    This test evaluates your software for content compliance with Windows Store Certification Requirements. Learn more

    Your app doesn't meet requirement 3.2. Learn more

    Commons reasons why apps fail this requirement:

    • The app crashes on launch.
    • The app crashes randomly or repeatedly.
    • The app freezes and the user has to close and restart the app.
    • The app requires a Windows component library that the Windows Store doesn't support. To avoid this, make sure your development tools are up-to-date.

    Notes from Testers:

    Unfortunately, when our reviewers tried to launch your app failed to launch every time. Our reviewers were unable to complete a review. If we were able to capture a crash report, we have provided it to you. Please see: http://go.microsoft.com/fwlink/?LinkId=279806 for information on how to work with the crash reports.

    And dump report is:-

    <Event xmlns='http://schemas.microsoft.com/win/2004/08/events/event'><System><Provider Name='Windows Error Reporting'/><EventID Qualifiers='0'>1001</EventID><Level>4</Level><Task>0</Task><Keywords>0x80000000000000</Keywords><TimeCreated SystemTime='2013-08-24T04:01:49.000000000Z'/><EventRecordID>491</EventRecordID><Channel>Application</Channel><Computer>W81</Computer><Security/></System><EventData><Data>TestBucket</Data><Data>4</Data><Data>MoAppCrash</Data><Data>Not available</Data><Data>2567</Data><Data>Lucky8Solutions.TabletInvoicePro_1.0.0.48_neutral__024d74sc3x1gy</Data><Data>praid:App</Data><Data>1.0.0.0</Data><Data>5217554b</Data><Data>WorkInvoicePro</Data><Data>1.0.0.0</Data><Data>5217554b</Data><Data>System.BadImageFormatException</Data><Data>74ace</Data><Data></Data><Data>
    C:\Users\TestVendor\AppData\Local\Temp\WERF577.tmp.WERInternalMetadata.xml
    C:\Users\TestVendor\AppData\Local\Temp\WERF644.tmp.appcompat.txt
    C:\Users\TestVendor\AppData\Local\Temp\WERF683.tmp.dmp</Data><Data>C:\Users\TestVendor\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_Lucky8Solutions._4f3b9aded8f3c577a4294a55121b64a584f225a6_cab_0b01f79a</Data><Data></Data><Data>0</Data><Data>e5e58ca9-0c71-11e3-be6c-20689d3a4b38</Data><Data>8</Data><Data>TestBucket</Data></EventData></Event>


    sandeep chauhan

    Monday, August 26, 2013 10:55 AM

All replies

  • My guess is that you're trying to use a DLL that has a different compilation type than the app, such as an ARM app using a 32-bit or 64-bit DLL.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Monday, August 26, 2013 6:53 PM
    Moderator
  • The fact that it fails to launch every time for the reviewers reminds me of an issue I was having. Are you developing on Windows 8.1 by any chance?

    When developing a Windows 8.0 app on Windows 8.1 you may find that your app will compile and run fine on 8.1 but will crash on 8.0.

    In my case I was using a value in a textblock for WrapWholeWords, which is not available in 8.0 apps, but Visual Studio still let me use the value in my 8.0 app.

    If you're using 8.1 try deploying the app to an 8.0 device and see if you can replicate the crash.


    I'm a self-taught noob amateur. Please take this into account when responding to my posts or when taking advice from me.

    Tuesday, August 27, 2013 3:44 AM
  • Hi ,

    Difficult to figure out why this is happening because we don't have your solution.
    Did you develop your app in a VMachine ??

    Because this could be the source of a lot of problems. The first of all is the performance. I had some similar issues because I used VM and after a restart was fixed.

    thank you

    Tuesday, August 27, 2013 5:38 AM
  • Hi,

    I would suggest you to compile your application for windows 8.0 compiling for AnyCpu.

    in this way you make quite sure that the application works for everybody.

    Also, do not rely on the emulator, but plug your device and deploy the app on your test device.


    Tuesday, August 27, 2013 6:25 AM
  • Hi,

    I would suggest you to compile your application for windows 8.0 compiling for AnyCpu.

    Note: compiling for 8.0 isn't enough - you need to test the app on a Windows 8.0 machine as it can compile and work perfectly well on an 8.1 device but still not work on 8.0 devices. Targeting/compiling to 8.0 is not enough to ensure it works on 8.0 devices.

    See details of my issues with this here: http://social.msdn.microsoft.com/Forums/windowsapps/en-US/69b926e9-63cb-4f5c-ab6b-8f684792296f/why-does-using-wraptowholewords-crash-my-app


    I'm a self-taught noob amateur. Please take this into account when responding to my posts or when taking advice from me.

    Tuesday, August 27, 2013 6:28 AM