none
The host on which MQSC adapter is running is getting stopped while running BizTalk application. RRS feed

  • Question

  • Hi All,

    I am using MQSC adapter to communicate with an IBM Queue. While running the application, receive and send hosts on which MQSC adapter is running are getting stopped and the below error is logged in event log.

    Application: BTSNTSvc64.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.AccessViolationException
    Stack:
       at <Module>.ImqQue.{dtor}(ImqQue*)
       at <Module>.ImqQue.{dtor}(ImqQue*)
       at <Module>.ImqQue.__vbaseDtor(ImqQue*)
       at <Module>.MQSeriesInputImplBase.WaitFor(MQSeriesInputImplBase*, Int32)
       at Microsoft.BizTalk.Adapter.Mqsc.MQSeriesInput.WaitFor(Int32)
       at Microsoft.BizTalk.Adapter.Mqsc.MqscReceiverTask.Listener()
       at Microsoft.BizTalk.Adapter.Mqsc.MqscReceiverTask.ThreadProc()
       at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
       at System.Threading.ThreadPoolWorkQueue.Dispatch()

    I have done the changes in BTSNTSVC64.exe.config by following the below link but still I am facing the above issue.

    https://blogs.msdn.microsoft.com/biztalkcpr/2013/09/23/biztalk-2013-hosts-crashing/

    Can anyone help me what might be the reason for this issue and how to resolve it. Any help will be appreciated. I am using BizTalk 2013R2 and HIS2013 is installed in my machine.


    Kiran Valluru.





    Wednesday, September 28, 2016 1:33 PM

Answers

  • Hi Kiran

    Apart from what Mandar suggested, also install HIS CU3.


    Thanks Arindam

    • Marked as answer by Kiran Valluru Friday, October 14, 2016 1:58 PM
    Thursday, September 29, 2016 3:41 AM
    Moderator
  • Hi Kiran,

    Please follow the given link below and install the latest cumulative update for the version of BizTalk that you have.

    List Of Biztalk Cumulative Updates

    Few things to note though

    1. Make sure that you test the CU on your dev box and then move it up the environments.
    2. Make sure that while installing the CU you have backed up you BizTalk apps and you have complete downtime meaning al the Host Instances and IIS should be stopped
    3. All the BizTalk Databases are backed up.

    Regards,


    Mandar Dharmadhikari

    • Proposed as answer by Angie Xu Thursday, October 6, 2016 6:20 AM
    • Marked as answer by Angie Xu Thursday, October 6, 2016 6:20 AM
    • Unmarked as answer by Kiran Valluru Friday, October 14, 2016 1:58 PM
    • Marked as answer by Kiran Valluru Friday, October 14, 2016 1:58 PM
    Wednesday, September 28, 2016 2:03 PM

All replies

  • Hi Kiran valluru,

    Do you have the latest cumulative update installed on your server???

    Also please change the type of this from discussion to a question.

    Regards,


    Mandar Dharmadhikari

    Wednesday, September 28, 2016 1:40 PM
  • Hi,

    What version of MQ you are using and what BizTalk version as well?

    BTW make it a practice to back up your config file before any change, what change you did in config and to fix what?


    Regards Pushpendra Singh : Please mark the reply as answer or vote it up, as deemed fit.


    Wednesday, September 28, 2016 1:40 PM
  • Hi Pushpendra Singh,

    I am using BizTalk 2013R2 and MQ 7.5 version.


    kiran Valluru

    Wednesday, September 28, 2016 1:50 PM
  • Hi Mandar,

    I have not installed any latest update on my server. Can you help me with the link where I can download it ?


    kiran Valluru

    Wednesday, September 28, 2016 1:54 PM
  • Hi Kiran,

    Please follow the given link below and install the latest cumulative update for the version of BizTalk that you have.

    List Of Biztalk Cumulative Updates

    Few things to note though

    1. Make sure that you test the CU on your dev box and then move it up the environments.
    2. Make sure that while installing the CU you have backed up you BizTalk apps and you have complete downtime meaning al the Host Instances and IIS should be stopped
    3. All the BizTalk Databases are backed up.

    Regards,


    Mandar Dharmadhikari

    • Proposed as answer by Angie Xu Thursday, October 6, 2016 6:20 AM
    • Marked as answer by Angie Xu Thursday, October 6, 2016 6:20 AM
    • Unmarked as answer by Kiran Valluru Friday, October 14, 2016 1:58 PM
    • Marked as answer by Kiran Valluru Friday, October 14, 2016 1:58 PM
    Wednesday, September 28, 2016 2:03 PM
  • Hi,

    with MQ 7.5 Install Cumulative updates and retry.

    https://support.microsoft.com/en-us/kb/2555976


    Regards Pushpendra Singh : Please mark the reply as answer or vote it up, as deemed fit.

    Wednesday, September 28, 2016 4:16 PM
  • Hi Kiran

    Apart from what Mandar suggested, also install HIS CU3.


    Thanks Arindam

    • Marked as answer by Kiran Valluru Friday, October 14, 2016 1:58 PM
    Thursday, September 29, 2016 3:41 AM
    Moderator
  • Thanks Arindam and Mandar.

    I ve installed HIS CU3 alone and it worked for me. Thanks a lot for your support.

    Regards,

    Kiran


    kiran Valluru

    Friday, October 14, 2016 1:58 PM