locked
SQL Backups to Azure started to fail due to timeout RRS feed

  • Question

  • I'm backing up some SQL dbs to Azure. Everything went smoothly during the trial period. Once I confirmed my subscription, backups worked for a couple of days then started to fail with the following message: 

    Executed as user: xxx\SqlUser. 10 percent processed. [SQLSTATE 01000] (Message 3211)  Write on "https://xxxx.blob.core.windows.net/xxxxx/xxxxxx.bak" failed: Backup to URL received an exception from the remote endpoint. Exception Message: The client could not finish the operation within specified timeout. [SQLSTATE 42000] (Error 3202)  A nonrecoverable I/O error occurred on file "https://xxxx.blob.core.windows.net/xxxxx/xxxxxx.bak:" Error could not be gathered from Remote Endpoint. [SQLSTATE 42000] (Error 3271)  BACKUP DATABASE is terminating abnormally. [SQLSTATE 42000] (Error 3013).  The step failed.

    I'm running same jobs, same scripts, ... Can't find an explanation. Tried even different hours with no avail.

    TIA for any suggestions,

    Jane

    Wednesday, May 31, 2017 9:21 AM

All replies

  • Are you running Azure SQL Database or SQL Server on an Azure VM? What backup utility are you using?
    Thursday, June 1, 2017 2:55 AM
  • I'm using SQL Server 2014 on my own hardware.  The funny thing is that the same jobs and configuration worked perfectly for a couple of years on a Bizspark Azure account and for a couple of weeks also on my new account. I don't know what's wrong now.

    I back up two DBs of about 100 GB each. Sometimes they are successful, but fail most of the times.

    On the same account, I'm able to  successfully backup a SQL 2005 DB of about 200 GB using SQL2AzureBackup utility.

    Friday, June 2, 2017 10:41 AM
  • I couldn't locate this backup utility 'SQL2AzureBackup' online that you've mentioned. I suggest you create a technical support ticket to troubleshoot this issue as it certainly requires deeper analysis beyond the purview of forums.
    Sunday, June 4, 2017 5:19 AM
  • Well, I've just mixed up the name. The correct one is SQLBackup2Azure. Not so much difference and, certainly, not one that could prevent a person that qualifies himself as "moderator" to locate such utility, which, after all, is a Microsoft utility.

    Anyway, I realize that this forum has been made up to redirect users to paid support, without providing any meaningful help. Not a big problem. It's easy to switch to another service.

    Cheers,

    Jane

    Sunday, June 4, 2017 10:31 AM