locked
SQL 2008 R2 error when lunching LandingPage.exe RRS feed

  • Question

  • Hi I'm trying to install SQL 2008 R2 in an Win7 64bits computer and I'm getting this error:

    Unknown error (0xfffffffe)

    I have checked Detail_LandingPage.txt and I'm get these entries:

    2010-11-02 15:55:25 Slp: ----------------------------------------------------------------------

    2010-11-02 15:55:25 Slp: Running Action: LandingPage

    2010-11-02 15:55:25 Slp: Landing page action

    2010-11-02 15:55:25 Slp: Starting Landing Page: Path = D:\SQLEXPR2008R2 WT_x64_ENU\x64\LandingPage.exe, Arguments =  /ENU /MEDIASOURCE="D:\SQLEXPR2008R2 WT_x64_ENU\\"

    2010-11-02 15:56:39 Slp: Completed Action: LandingPage, returned True

    2010-11-02 15:56:40 Slp: 

    2010-11-02 15:56:40 Slp: 

    2010-11-02 15:56:40 Slp: ----------------------------------------------------------------------

    2010-11-02 15:56:40 Slp: 

    2010-11-02 15:56:40 Slp: Setup result: 0


    If I run at CMD console the commmand D:\SQLEXPR2008R2 WT_x64_ENU\x64\LandingPage.exe, Arguments =  /ENU /MEDIASOURCE="D:\SQLEXPR2008R2 WT_x64_ENU\\"  I get this error (in Spanish):

    Windows security

    Can't open these files

    Setup Internet security does'nt allow open this file:

    D:\SQLEXPR2008R2 WT_x64_ENU\x64\landingpage.exe

     

    Please can you help me?

    Cheers

     


    Thanks for your valuable help - Yours, Josep Balague
    Tuesday, November 2, 2010 3:01 PM

Answers

  • Hi Chunsong,

    I followed your steps and the problem persists.

    I will format the computer and try again

    Thanks


    Thanks for your valuable help - Yours, Josep Balague
    • Marked as answer by Josep Balague Friday, November 5, 2010 7:59 AM
    Friday, November 5, 2010 7:58 AM

All replies

  • Try deleting the folder (it may be a hidden folder) and contains files for older versions of SQLExpress.  Where this is depends a bit on your setup. 

    C:\Users\<USERNAME>\AppData\Local\Microsoft_Corporation

    C:\Users\<USERNAME>\AppData\Local\Microsoft\Microsoft SQL Server Data\SQLEXPRESS

    C:\Documents and Settings\<USERNAME>\Local Settings\Application Data\Microsoft\Microsoft SQL Server Data\SQLEXPRESS


    http://social.msdn.microsoft.com/Forums/en/sqlexpress/thread/a6b332fb-69c1-4253-b283-4b396671cbe5

    http://social.msdn.microsoft.com/Forums/en-US/sqlsetupandupgrade/thread/e5a91091-5635-42bd-9ddc-7925e3bba688

    RLF

     

    Wednesday, November 3, 2010 2:10 PM
  • Hi Russell,

    thanks for your answer.

    My \AppData\Local\Microsoft_Corporation had a folder called LandingPage.exe_StrongName_.... I deleted it and it is still not working: same error...

    I guess there are no other SQL server folder under Local folder.

    Other suggestions?

    Cheers


    Thanks for your valuable help - Yours, Josep Balague
    Wednesday, November 3, 2010 3:12 PM
  • Now that you have deleted the folder, please try once again to install SQL Express and see if it buttons up everything correctly this time.

    RLF

    Wednesday, November 3, 2010 3:20 PM
  • Russell,

     

    after removing ALL SQL server folders of disk, the error is still there. Same error Unknown error (0xfffffffe). This error is general to installer because it happens at all options of main menu. May it be something related to credentials?

    Other suggestions?


    Thanks for your valuable help - Yours, Josep Balague
    Thursday, November 4, 2010 7:48 AM
  • Hi,

    Please change D:\SQLEXPR2008R2 WT_x64_ENU\x64\LandingPage.exe, Arguments =  /ENU /MEDIASOURCE="D:\SQLEXPR2008R2 WT_x64_ENU\\" to "D:\SQLEXPR2008R2 WT_x64_ENU\x64\LandingPage.exe", Arguments =  /ENU /MEDIASOURCE="D:\SQLEXPR2008R2 WT_x64_ENU\\".

    However, it only helps you open SQL Server Installation Center, actually you can double click setup.exe under D:\SQLEXPR2008R2 WT_x64_ENU folder. If you want to run the setup from command line, please see How to: Install SQL Server 2008 R2 from the Command Prompt (http://msdn.microsoft.com/en-us/library/ms144259.aspx).

    Please let us know if you have more questions.

    Hope this helps.

    Thanks,
    Chunsong


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 4, 2010 9:16 AM
  • Hi ChungSong,

    I have detect when running landingpage.exe at command line (with your suggestions and without parameters) I'm getting access denied message.

    I have checked ntfs permisions and they seem to be right because I can run other programs from my D: unit. 

    Other suggestions?


    Thanks for your valuable help - Yours, Josep Balague
    Thursday, November 4, 2010 10:14 AM
  • Hi,

    It is probably due to UAC (User Access Control) on Windows 7. You can run cmd as administrator or directory run setup.exe (D:\SQLEXPR2008R2 WT_x64_ENU\setup.exe) as administrator.

    To run command prompt as administrator, please Click Start -> All Programs -> Accessories, right-click Command Prompt and select Run as administrator. To run setup.exe as administrator, please right-click setup.exe and select Run as administrator.

    Besides, the installation media might be corrupted, if this is the case, please download a new copy from SQL Server 2008 R2 Express Edition or SQL Server 2008 R2 Express with Management Tools.

    Hope this helps.

    Thanks,
    Chunsong


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, November 5, 2010 1:26 AM
  • Hi Chunsong,

    I followed your steps and the problem persists.

    I will format the computer and try again

    Thanks


    Thanks for your valuable help - Yours, Josep Balague
    • Marked as answer by Josep Balague Friday, November 5, 2010 7:59 AM
    Friday, November 5, 2010 7:58 AM
  • same problem, worked for me. thank you.
    Friday, November 12, 2010 12:10 PM
  • same problem, worked for me. thank you.
    Friday, November 12, 2010 12:11 PM