none
Kinect Studio no longer working - exits immediately RRS feed

  • Question

  • Hi,

    So started a new Kinect project today and discovered that Kinect Studio is broken. Clicking the app will launch it and show the splash screen then it just disappears, exits and I don't see anything in the taskmanager except for 'KStudioHostService.exe'.

    Kinect Studio was working fine back in June as that was the last time I used it with a different project.

    Since that time I had to update windows 10 to 1903 (18362.356) from 1709 ( I think, bad update experiences forced me to prevent automatic updates for a long time ) in order to run some other Microsoft software. I guess this led to breaking the actual Kinect since it didn't work until I followed the advice to update the driver & runtime. For several years now i've relied solely on Kinect studio and recordings since it was far easier to develop with. Losing this ability will make further development a real chore.

    After updating the driver and runtime the physical Kinect appears to work fine both with SDK samples and my own previous applications, its just the Kinect Studio and Kinect Gesture builder that fail to run for some reason.

    Wondering if anyone else has problems with Kinect Studio? Perhaps its unrelated to win 10 1903 though I cant think what else would prevent the app from running.


    I have installed

    KFW Runtime v2.2_1811
    KFW SDK V2.0_1409
    Kinect Evolution

    Neither Kinect Studio or Kinect Gesture Builder will run, both show start up screen then exit.
    I have uninstalled the SDK, restarted and reinstalled the sdk - was necessary as the SDK Browser lost all references to the projects and applications, and whilst it fixed the references Studio still doesn't work.
    All KFW samples from the SDK browser appear to work, Body Basics, Color Basics etc.
    Kinect Configuration Verifier comes back clean, with exception of USB 3 being a question mark, but thats always been the case and has never stopped either the Kinect or Studio from working in the past.

    Update:

    Checking Event Viewer I found the following when trying to launch Kinect Studio

    EventId 1026 - .NET Runtime

    Application: KStudio.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: exception code c0000005, exception address 00007FFD0558C416

    EventID 1000 - Application Error

    Faulting application name: KStudio.exe, version: 2.0.1410.19000, time stamp: 0x54441bc3
    Faulting module name: d3d9.dll, version: 10.0.18362.329, time stamp: 0x1ac9a115
    Exception code: 0xc0000005
    Fault offset: 0x00000000000ac416
    Faulting process ID: 0x42c4
    Faulting application start time: 0x01d56f5a7c8f97c6
    Faulting application path: C:\Program Files\Microsoft SDKs\Kinect\v2.0_1409\Tools\KinectStudio\KStudio.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\d3d9.dll
    Report ID: c22fbc3d-b41d-4f4c-8a08-d131519abac2
    Faulting package full name: 
    Faulting package-relative application ID: 

    • Edited by noisecrime Friday, September 20, 2019 2:41 AM
    Friday, September 20, 2019 2:35 AM

All replies

  • Edit - Oct 8 2019 
    Ok I think i've found the true culprit, although the workaround posted before still works and might still be better solution.

    So I was trying to launch another application Sony Vegas 14 and it just kept crashing. The log stated it was d3d9.dll as the cuase ( again ). This time the trick of adding d3d9.dll to the Vegas 14 directory didn't work. So I looked online and found a comment that it would crash if you were using MSI Afterburner. I disabled Afterburner and sure enough it started working fine.

    I'm unsure when this incompatability arose. I rarely update Afterburner and have had it running since 2014 on this PC, while Vegas 14 had worked for a good year or so on the same system with no problems. It may still be an incompatability with a d3d9.dll windows update in combination with Afterburner or something.

    I tried updating Afterburner to latest version 4.6.1 ( previously was using 4.4.2 and 4.4.1 ) but sadly that didn't resolve the problem.

    Anyway I removed the d3d9.dll that I added from KinectStudio, disabled Afterburner and tried launching it. Sure enough it worked fine!

    So yeah MSI Afterburner appears to cause several other applications to crash on start up. The overall solution is to close afterburner or just uninstall if you feel safe not running it. That should fix issues with a wide range of software crashing on start up due to an issue with d3d9.dll. Alternatively you can leave Afterburner alone and like the previous post simply copy an older version of d3d9.dll into the KinectStudio folder.

    Original Post

    After extensive online searching and digging for a solution I believe I've found a workaround!

    I simply placed an earlier version of d3d9.dll ( 64 bit version ) into the Kinect Studio application folder. I assume that Kinect Studio when loading the dll first looks in the application folder before using the system version and thus is now using this older version instead of the recently updated one ( assumed to be from win 10 update ).

    Now when launching Studio it loads up and I've been able to load a previous recording and play it back - yay!



    This leads me to believe that the system d3d9.dll is to blame ( as indicated by looking at the EventViewer - see above ), but i've no idea what caused it to be updated beyond say win 10 update? As far as I can tell from my system, the d3d9.dll was updated on 15 sept 2019, though the system32 version states it was created in aug 2019.

    So the process I followed was

    1. In Explorer perform a search for d3d9.dll on the C drive ( OS drive )

    2. I can see System32 and SysWow64 versions of the dll were modified on 15.09.2019 and i assume are version 10.0.18362.329

    3. I can see what I assume are previous back ups of d3d9.dll in the winSxs folder that had modification date of 24.07.2019 and version 10.0.18362.267

    4. I selected the previous d3d9 found at 'C:\Windows\WinSxS\amd64_microsoft-windows-directx-direct3d9_xxxxxxxxxxxxx_10.0.18362.267xxxxxxxxx'  ( x's replace some random id numbers ) and right-clicked to 'open file location'

    5. From there i simply copied the d3d9.dll into the Kinect Studio application folder ( next to the exe )


    Hope this information can help anyone else with the same problem and maybe provide a hint for anyone from MS to fix this issue.


    • Edited by noisecrime Wednesday, October 9, 2019 3:02 AM Found the true culprit!
    Saturday, September 21, 2019 3:17 PM
  • May I ask a question?Where do you have installed Kinect evolution sdk?I don't have it in my sdk browser
    Sunday, April 5, 2020 11:18 AM