locked
format of field in report rdlc RRS feed

  • Question

  • I have a report rdlc, which filled with a dataset that brings some fields from the sql database, one of the fields is of the decimal type, to receive this field I have defined my dataset with a field also decimal.
    But when displaying the field in a textbox within a tablix in the report the decimal separator field is a comma, when it should be a point, in which part I can change this setting.
    I already tried to change it in the textbox configuration inside the tablix in general and number,also i tried to get the regional configuration of my pc

    Nothing seems to work,
    I attach the images

    Thanks in advance, 



    • Edited by Augusto C Wednesday, November 9, 2016 2:36 AM
    Wednesday, November 9, 2016 2:32 AM

Answers

All replies

  • Hello Augusto,

    Have you defined any different language Setting in your Report or text box? Set the Locale for a Report or Text Box (Reporting Services)

    You could give it a try and force a language setting with it.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    • Marked as answer by Augusto C Wednesday, November 9, 2016 1:59 PM
    Wednesday, November 9, 2016 7:55 AM
  • Hi Augusto C,

    Based on my test, I didn’t reproduce the issue.

    As Olaf posted, please try to set the locale for the report or Text Box.

    For more information about Windows Regional Settings and Number Formatting in RDLC Reports, please refer to following article:

    Best Regards,
    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, November 9, 2016 9:26 AM
  • Hello,
    Thanks for the answers.
    I changed it in the properties (attached image), and the report also changed, I guess I should always change it there from now on.

    Wednesday, November 9, 2016 1:58 PM