none
Basic/Public Website key not returning result RRS feed

  • Question

  • Hi,

    I have created one key with type Basic/Public website on 10-Sept-2015, it was working for sometime for same day. After a day, when I try it is not giving result. Following response i am getting when i launch through browser.

    {"authenticationResultCode":"ValidCredentials","brandLogoUri":"http:\/\/dev.virtualearth.net\/Branding\/logo_powered_by.png","copyright":"Copyright © 2015 Microsoft and its suppliers. All rights reserved. This API cannot be accessed and the content and any results may not be used, reproduced or transmitted in any manner without express written permission from Microsoft Corporation.","resourceSets":[{"estimatedTotal":0,"resources":[]}],"statusCode":200,"statusDescription":"OK","traceId":"9393c584a68c464690e29251a13a70c5|HK20240353|02.00.207.200|HK2SCH010280426"}

    After that I have created one new key with type Basic/Dev/Test, this key also not working.

    When I create, I looked at the usage limit it has 120,000 non billable transaction. But after making couple of requests, it is not working

    Also I would like to indicate that, those successful response worked only on browser, when I tried through coding, it didnt work. After that moment onwards, none of my requests was successful

    Can someone please help me on figure out what is the issue.

    Any help would be appreciated


    Saturday, September 12, 2015 2:23 PM

Answers

  • This has been answered several times. What is happening is that your account is being rate limited. All basic and trial accounts are subject to being rate limiting. Rate limiting occurs when one of two things happens. The first is if you make a lot of requests in a short period of time such that you are likely to exceed the free terms of use. The second is if the servers are under a lot of load. In either case the service will limit the number of requests that it will process from basic and trial accounts and return an empty response. This is done to ensure that these accounts do not affect the service for Enterprise accounts. Rate limited responses have a flag in the header of the response that indicates that it has been rate limited. This is documented here: https://msdn.microsoft.com/en-us/library/ff701703.aspx Rate limiting can last a few minutes some times and other times could last a couple of days, depending on what the issue is.

    http://rbrundritt.wordpress.com


    Monday, September 14, 2015 3:27 PM