locked
sql server it is taking high memory RRS feed

  • Question

  • sql server  it is taking high memory 
    • Moved by Bill_Stewart Wednesday, February 22, 2017 7:31 PM Move to more appropriate forum
    Wednesday, February 22, 2017 9:06 AM

Answers

  • Hi Maneeshreddy,

    you may want to configure the upper limit of how much memory an instance is allowed to claim.

    You can either configure that using the SQL Management Studio or by using the dbatools' "Set-DbaMaxMemory" function.

    Cheers,
    Fred


    There's no place like 127.0.0.1

    Wednesday, February 22, 2017 9:25 AM
  • Hi maneeshreddy,

    Please correct me if I’m wrong:

    >>sql server  it is taking high memory

    SQL Server, by its nature, will try to maximize memory unitization when possible. If your machine is not dedicated for SQL Server, you might wish to set max server memory to a proper value to avoid potential issue.

    If you have any other questions, please let me know.

    Regards,
    Lin

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, February 23, 2017 3:07 AM

All replies

  • Hello

    You need to post this in https://social.technet.microsoft.com/Forums/en-US/home?category=sqlserver forum


    Regards, Regin Ravi

    Wednesday, February 22, 2017 9:09 AM
  • Hi Maneeshreddy,

    you may want to configure the upper limit of how much memory an instance is allowed to claim.

    You can either configure that using the SQL Management Studio or by using the dbatools' "Set-DbaMaxMemory" function.

    Cheers,
    Fred


    There's no place like 127.0.0.1

    Wednesday, February 22, 2017 9:25 AM
  • Hi maneeshreddy,

    Please correct me if I’m wrong:

    >>sql server  it is taking high memory

    SQL Server, by its nature, will try to maximize memory unitization when possible. If your machine is not dedicated for SQL Server, you might wish to set max server memory to a proper value to avoid potential issue.

    If you have any other questions, please let me know.

    Regards,
    Lin

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, February 23, 2017 3:07 AM
  • To clarify...SQS and other subsystems like SharePoint allocate ALL available  memory then give back memory to  the system as needed.  On a properly provisioned server this is never a problem.

    \_(ツ)_/

    Thursday, February 23, 2017 3:40 AM
  • sql server  it is taking high memory 

    First of all take some time to write question in details, how could you expect detailed answer when you ask one line question. I normally put this question as off topic.

    SQL Server taking more memory is quite normal this is how it works, limit the SQL Server max server memory. And before all that go ahead and read lot of useful resources on internet and learn how SQL Server memory works 


    Cheers,

    Shashank

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My TechNet Wiki Articles

    MVP

    Thursday, February 23, 2017 4:11 AM

  • We can also use a system stored procedure to set the memory limits. http://www.teratrax.com/sp_configure-limit-sql-server-memory-usage/


    \_(ツ)_/


    • Edited by Shanky_621MVP Friday, February 24, 2017 6:48 AM removed off topic comment
    Thursday, February 23, 2017 10:17 AM
  • Hi Folks,

    With all your permission I will be deleting all posts (including mine) which are not related to the question just to clean the thread. I hope you guys agree


    Cheers,

    Shashank

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My TechNet Wiki Articles

    MVP

    Friday, February 24, 2017 6:46 AM
  • Hi,

    just to be sure: You did restart the service after applying those settings, right?

    Other than that, if all instances are configured for maximum memory consumption, and it still takes too much ... sorry, no idea why that's happening :(

    Cheers,
    Fred


    There's no place like 127.0.0.1

    Wednesday, March 15, 2017 9:50 AM
  • Thanks For Your Reply

    maneeshreddy

    Wednesday, March 15, 2017 10:09 AM
  • Hi,

    just to be sure: You did restart the service after applying those settings, right?

    You dont need to restart after changing SQL Server max server memory or min server memory, it automatically takes effect.

    Maneesh,

    It would have been better if you would have unmarked the answer when it was marked when you did not got the solution. You came back to this after so long anyways SQL Server taking all the memory allocated to it is normal this is how it works and this is not an issue, this is what I wrote in my very first reply.

    Now what is output of

    select @@version
    go
    select * from sys.dm_os_process_memory


    Cheers,

    Shashank

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My TechNet Wiki Articles

    MVP

    Wednesday, March 15, 2017 10:50 AM

  • select @@version                                                         

    No column name)

    Microsoft SQL Server 2008 (SP4) - 10.0.6000.29 (X64)   Sep  3 2014 04:11:34   Copyright (c) 1988-2008 Microsoft Corporation  Standard Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1) 


    select * from sys.dm_os_process_memory

    physical_memory_in_use_kb
    12277976

    SQL Server is using 11.70 GB and you have allocated 12GB this is completely normal. It is the other resources which are using memory. If you really feel you want to see the graph low add more RAM on the system

    Cheers,

    Shashank

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My TechNet Wiki Articles

    MVP

    Wednesday, March 15, 2017 2:10 PM
  • That is completely normal and expected behavior.  SQL Server does not release memory unless the server is under memory pressure.

    Please see:

    https://msdn.microsoft.com/en-us/library/ms178067(v=sql.110).aspx

    Wednesday, March 15, 2017 6:28 PM
    Answerer